[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAM_iQpXyjg+d7idQBfmwX7PQgC5upaTC9327wPjMFVNNn=EAkQ@mail.gmail.com>
Date: Wed, 14 Oct 2015 21:15:31 -0700
From: Cong Wang <xiyou.wangcong@...il.com>
To: Jamal Hadi Salim <jhs@...atatu.com>
Cc: Linux Kernel Network Developers <netdev@...r.kernel.org>
Subject: Re: [Patch net-next 1/4] net_sched: introduce qdisc_replace() helper
On Wed, Oct 14, 2015 at 4:56 AM, Jamal Hadi Salim <jhs@...atatu.com> wrote:
> On 10/12/15 14:38, Cong Wang wrote:
>>
>> Remove nearly duplicated code and prepare for the following patch.
>>
>
>
> Cong - like Dave, I dont see equivalence in some of these
> changes.
> Example not sure how the qfq grafting invocation of
> qfq_purge_queue fits in. There are a few others.
drr_purge_queue() and qfq_purge_queue() are both
qdisc_reset() + qdisc_tree_decrease_qlen():
static void drr_purge_queue(struct drr_class *cl)
{
unsigned int len = cl->qdisc->q.qlen;
qdisc_reset(cl->qdisc);
qdisc_tree_decrease_qlen(cl->qdisc, len);
}
static void qfq_purge_queue(struct qfq_class *cl)
{
unsigned int len = cl->qdisc->q.qlen;
qdisc_reset(cl->qdisc);
qdisc_tree_decrease_qlen(cl->qdisc, len);
}
Or you mean the order of calling them??
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists