[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20151130.110607.1409128209032271059.davem@redhat.com>
Date: Mon, 30 Nov 2015 11:06:07 -0500 (EST)
From: David Miller <davem@...hat.com>
To: eric.dumazet@...il.com
Cc: netdev@...r.kernel.org
Subject: Re: [PATCH net-next] tcp: suppress too verbose messages in
tcp_send_ack()
From: Eric Dumazet <eric.dumazet@...il.com>
Date: Wed, 25 Nov 2015 13:50:50 -0800
> diff --git a/include/net/sock.h b/include/net/sock.h
> index 7f89e4ba18d1..ead514332ae8 100644
> --- a/include/net/sock.h
> +++ b/include/net/sock.h
> @@ -776,7 +776,7 @@ static inline int sk_memalloc_socks(void)
>
> static inline gfp_t sk_gfp_atomic(const struct sock *sk, gfp_t gfp_mask)
> {
> - return GFP_ATOMIC | (sk->sk_allocation & __GFP_MEMALLOC);
> + return gfp_mask | (sk->sk_allocation & __GFP_MEMALLOC);
> }
>
> static inline void sk_acceptq_removed(struct sock *sk)
Eric, please rename this to "sk_gfp_mask()" or "sk_gfp_flags()" or
something like that since it doesn't unconditionally use GFP_ATOMIC
any more.
Otherwise I'm %100 fine with this change.
Thank you.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists