[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <1453218163-31998-3-git-send-email-jprvita@endlessm.com>
Date: Tue, 19 Jan 2016 10:42:37 -0500
From: "João Paulo Rechi Vita" <jprvita@...il.com>
To: johannes@...solutions.net
Cc: marcel@...tmann.org, linux-wireless@...r.kernel.org,
davem@...emloft.net, netdev@...r.kernel.org,
linux-kernel@...r.kernel.org, jprvita@...lessm.com,
linux@...lessm.com
Subject: [PATCH 2/8] rfkill: Improve code readability
RFKILL_BLOCK_SW value have just been saved to prev, no need to check it
again in the if expression. This makes code a little bit easier to read.
Signed-off-by: João Paulo Rechi Vita <jprvita@...lessm.com>
---
net/rfkill/core.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/net/rfkill/core.c b/net/rfkill/core.c
index 4d6d726..838e869 100644
--- a/net/rfkill/core.c
+++ b/net/rfkill/core.c
@@ -285,7 +285,7 @@ static void rfkill_set_block(struct rfkill *rfkill, bool blocked)
spin_lock_irqsave(&rfkill->lock, flags);
prev = rfkill->state & RFKILL_BLOCK_SW;
- if (rfkill->state & RFKILL_BLOCK_SW)
+ if (prev)
rfkill->state |= RFKILL_BLOCK_SW_PREV;
else
rfkill->state &= ~RFKILL_BLOCK_SW_PREV;
--
2.5.0
Powered by blists - more mailing lists