[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1465319080.25087.28.camel@perches.com>
Date: Tue, 07 Jun 2016 10:04:40 -0700
From: Joe Perches <joe@...ches.com>
To: Pablo Neira Ayuso <pablo@...filter.org>, tcharding <me@...in.cc>
Cc: Stephen Hemminger <stephen@...workplumber.org>,
"David S. Miller" <davem@...emloft.net>,
netfilter-devel@...r.kernel.org, coreteam@...filter.org,
netdev@...r.kernel.org
Subject: Re: [PATCH 1/3] bridge: netfilter: checkpatch whitespace fixes
On Tue, 2016-06-07 at 17:14 +0200, Pablo Neira Ayuso wrote:
> On Tue, May 10, 2016 at 11:26:56AM +1000, tcharding wrote:
> > From: Tobin C Harding <me@...in.cc>
> > This is my second linux kernel patch. Unsure if I was meant to cc multiple mailing lists?
[]
> > diff --git a/net/bridge/netfilter/ebt_stp.c b/net/bridge/netfilter/ebt_stp.c
[]
> > @@ -55,65 +55,65 @@ static bool ebt_filter_config(const struct ebt_stp_info *info,
> > if (info->bitmask & EBT_STP_ROOTPRIO) {
> > v16 = NR16(stpc->root);
> > if (FWINV(v16 < c->root_priol ||
> > - v16 > c->root_priou, EBT_STP_ROOTPRIO))
> > + v16 > c->root_priou, EBT_STP_ROOTPRIO))
> I don't think this coding style is right. This is a common approach
> (to align the condition when split in several lines) in other 'net' code.
Perhaps you misread the code.
The alignment is changed for the 1st argument of the FWINV macro
to be more similar to the style used in the rest of net/
But using a longer initial line would be more readable:
if (FWINV(v16 < c->root_priol || v16 > c->root_priou,
EBT_STP_ROOTPRIO))
Powered by blists - more mailing lists