lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 25 Aug 2016 15:39:08 +0200
From:   John Crispin <john@...ozen.org>
To:     Sean Wang <sean.wang@...iatek.com>, davem@...emloft.net
Cc:     netdev@...r.kernel.org, nbd@...nwrt.org,
        linux-mediatek@...ts.infradead.org, keyhaede@...il.com
Subject: Re: [RESEND PATCH net 09/10] net: ethernet: mediatek: use
 devm_mdiobus_alloc instead of mdiobus_alloc inside mtk_mdio_init

Hi Sean,

small nitpick inline

On 25/08/2016 12:45, Sean Wang wrote:
> a lot of parts in the driver uses devm_* APIs to gain benefits from the
> device resource management, so devm_mdiobus_alloc is also used instead
> of mdiobus_alloc to have more elegant code flow.
> 
> Signed-off-by: Sean Wang <sean.wang@...iatek.com>
> ---
>  drivers/net/ethernet/mediatek/mtk_eth_soc.c | 13 +------------
>  1 file changed, 1 insertion(+), 12 deletions(-)
> 
> diff --git a/drivers/net/ethernet/mediatek/mtk_eth_soc.c b/drivers/net/ethernet/mediatek/mtk_eth_soc.c
> index e3baa63..05d85da 100644
> --- a/drivers/net/ethernet/mediatek/mtk_eth_soc.c
> +++ b/drivers/net/ethernet/mediatek/mtk_eth_soc.c
> @@ -304,7 +304,7 @@ static int mtk_mdio_init(struct mtk_eth *eth)
>  		goto err_put_node;
>  	}
>  
> -	eth->mii_bus = mdiobus_alloc();
> +	eth->mii_bus = devm_mdiobus_alloc(eth->dev);
>  	if (!eth->mii_bus) {
>  		err = -ENOMEM;
>  		goto err_put_node;
> @@ -318,18 +318,9 @@ static int mtk_mdio_init(struct mtk_eth *eth)
>  
>  	snprintf(eth->mii_bus->id, MII_BUS_ID_SIZE, "%s", mii_np->name);
>  	err = of_mdiobus_register(eth->mii_bus, mii_np);
> -	if (err)
> -		goto err_free_bus;
> -	of_node_put(mii_np);
> -
> -	return 0;
> -
> -err_free_bus:
> -	mdiobus_free(eth->mii_bus);
>  
>  err_put_node:
>  	of_node_put(mii_np);
> -	eth->mii_bus = NULL;
>  	return err;

you might want to rename err to ret. that would make it more readable.
right now it looks like the code always flows through the error path.

	John

>  }
>  
> @@ -339,8 +330,6 @@ static void mtk_mdio_cleanup(struct mtk_eth *eth)
>  		return;
>  
>  	mdiobus_unregister(eth->mii_bus);
> -	of_node_put(eth->mii_bus->dev.of_node);
> -	mdiobus_free(eth->mii_bus);
>  }
>  
>  static inline void mtk_irq_disable(struct mtk_eth *eth, u32 mask)
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ