[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20161203162413.5f305f9f@redhat.com>
Date: Sat, 3 Dec 2016 16:24:13 +0100
From: Jesper Dangaard Brouer <brouer@...hat.com>
To: Martin KaFai Lau <kafai@...com>
Cc: brouer@...hat.com, <netdev@...r.kernel.org>,
Alexei Starovoitov <ast@...com>,
Brenden Blanco <bblanco@...mgrid.com>,
Daniel Borkmann <daniel@...earbox.net>,
David Miller <davem@...emloft.net>,
Saeed Mahameed <saeedm@...lanox.com>,
Tariq Toukan <tariqt@...lanox.com>,
Kernel Team <kernel-team@...com>
Subject: Re: [PATCH net-next 1/4] bpf: xdp: Allow head adjustment in XDP
prog
On Fri, 2 Dec 2016 15:23:30 -0800
Martin KaFai Lau <kafai@...com> wrote:
> -bool bpf_helper_changes_skb_data(void *func)
> +BPF_CALL_2(bpf_xdp_adjust_head, struct xdp_buff *, xdp, int, offset)
> +{
> + /* Both mlx4 and mlx5 driver align each packet to PAGE_SIZE when
> + * XDP prog is set.
> + * If the above is not true for the other drivers to support
> + * bpf_xdp_adjust_head, struct xdp_buff can be extended.
> + */
> + void *head = (void *)((unsigned long)xdp->data & PAGE_MASK);
> + void *new_data = xdp->data + offset;
> +
> + if (new_data < head || new_data >= xdp->data_end)
> + /* The packet length must be >=1 */
> + return -EINVAL;
> +
> + xdp->data = new_data;
> +
> + return 0;
> +}
First time I read this code, I was about to complain about you didn't
use XDP_PACKET_HEADROOM in your boundary check. But then I noticed the
PAGE_MASK. If you rename "head" to "page_boundary" or "page_start"
then IMHO the code would be more readable.
--
Best regards,
Jesper Dangaard Brouer
MSc.CS, Principal Kernel Engineer at Red Hat
LinkedIn: http://www.linkedin.com/in/brouer
Powered by blists - more mailing lists