[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20170122144225.lvkakc7db7fs2xpq@ThinkPad>
Date: Sun, 22 Jan 2017 22:42:25 +0800
From: Geliang Tang <geliangtang@...il.com>
To: Leon Romanovsky <leon@...nel.org>
Cc: Yishai Hadas <yishaih@...lanox.com>, netdev@...r.kernel.org,
linux-rdma@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] net/mlx4: use rb_entry()
On Sun, Jan 22, 2017 at 09:48:39AM +0200, Leon Romanovsky wrote:
> On Fri, Jan 20, 2017 at 10:36:57PM +0800, Geliang Tang wrote:
> > To make the code clearer, use rb_entry() instead of container_of() to
> > deal with rbtree.
> >
> > Signed-off-by: Geliang Tang <geliangtang@...il.com>
> > ---
> > drivers/net/ethernet/mellanox/mlx4/resource_tracker.c | 8 ++++----
> > 1 file changed, 4 insertions(+), 4 deletions(-)
>
> I don't understand completely the rationale behind this conversion.
> rb_entry == container_of, why do we need another name for it?
>
There are several *_entry macros which are defined in kernel data
structures, like list_entry, hlist_entry, rb_entry, etc. Each of them is
just another name for container_of. We use different *_entry so that we
could identify the specific type of data structure that we are dealing
with.
-Geliang
Powered by blists - more mailing lists