lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Sun, 19 Feb 2017 12:01:15 -0800
From:   Stephen Hemminger <stephen@...workplumber.org>
To:     Jiri Pirko <jiri@...nulli.us>
Cc:     netdev@...r.kernel.org, ogerlitz@...lanox.com, mlxsw@...lanox.com
Subject: Re: [patch iproute2/net-next] devlink: use DEVLINK_CMD_ESWITCH_*
 instead of DEVLINK_CMD_ESWITCH_MODE_*

On Sun, 19 Feb 2017 15:37:06 +0100
Jiri Pirko <jiri@...nulli.us> wrote:

> From: Jiri Pirko <jiri@...lanox.com>
> 
> Sync with kernel and don't use the obsolete enum values.
> 
> Signed-off-by: Jiri Pirko <jiri@...lanox.com>
> ---
>  devlink/devlink.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/devlink/devlink.c b/devlink/devlink.c
> index 34a409f..c357580 100644
> --- a/devlink/devlink.c
> +++ b/devlink/devlink.c
> @@ -1303,7 +1303,7 @@ static int cmd_dev_eswitch_show(struct dl *dl)
>  	struct nlmsghdr *nlh;
>  	int err;
>  
> -	nlh = mnlg_msg_prepare(dl->nlg, DEVLINK_CMD_ESWITCH_MODE_GET,
> +	nlh = mnlg_msg_prepare(dl->nlg, DEVLINK_CMD_ESWITCH_GET,
>  			       NLM_F_REQUEST | NLM_F_ACK);
>  
>  	err = dl_argv_parse_put(nlh, dl, DL_OPT_HANDLE, 0);
> @@ -1321,7 +1321,7 @@ static int cmd_dev_eswitch_set(struct dl *dl)
>  	struct nlmsghdr *nlh;
>  	int err;
>  
> -	nlh = mnlg_msg_prepare(dl->nlg, DEVLINK_CMD_ESWITCH_MODE_SET,
> +	nlh = mnlg_msg_prepare(dl->nlg, DEVLINK_CMD_ESWITCH_SET,
>  			       NLM_F_REQUEST | NLM_F_ACK);
>  
>  	err = dl_argv_parse_put(nlh, dl, DL_OPT_HANDLE,

I went back and looked at the original commit.
    devlink: fix the name of eswitch commands
OK, so you only changed the name, not the value so it would be binary
compatible.

Applied.

Powered by blists - more mailing lists