[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20170414155737.24d3ce38@xeon-e3>
Date: Fri, 14 Apr 2017 15:57:37 -0700
From: Stephen Hemminger <stephen@...workplumber.org>
To: David Ahern <dsa@...ulusnetworks.com>
Cc: netdev@...r.kernel.org
Subject: Re: [PATCH iproute2] ip vrf: Add command name next to pid
Overall, this looks like a good idea.
> +
> +int get_comm(char *pid, char *comm, int len)
Please use more glibc style function signature, like:
int get_comm(const char *pid, char *comm, size_t len)
And maybe even
int get_command_name(pid_t pid, char *comm, size_t len)
Powered by blists - more mailing lists