[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAM_iQpUZKjR1SXVaHNq4fRiiFx8-X=mjK+k=4TDvxd5CuK4gyw@mail.gmail.com>
Date: Tue, 16 May 2017 15:34:04 -0700
From: Cong Wang <xiyou.wangcong@...il.com>
To: David Miller <davem@...emloft.net>
Cc: Jiri Pirko <jiri@...nulli.us>,
Linux Kernel Network Developers <netdev@...r.kernel.org>,
Jamal Hadi Salim <jhs@...atatu.com>,
David Ahern <dsa@...ulusnetworks.com>,
Eric Dumazet <edumazet@...gle.com>,
Stephen Hemminger <stephen@...workplumber.org>,
Daniel Borkmann <daniel@...earbox.net>,
Alexander Duyck <alexander.h.duyck@...el.com>,
Simon Horman <simon.horman@...ronome.com>, mlxsw@...lanox.com
Subject: Re: [patch net-next v3 02/10] net: sched: introduce tcf block infractructure
On Tue, May 16, 2017 at 2:34 PM, David Miller <davem@...emloft.net> wrote:
> From: Cong Wang <xiyou.wangcong@...il.com>
> Date: Tue, 16 May 2017 13:51:30 -0700
>
>> On Tue, May 16, 2017 at 10:27 AM, Jiri Pirko <jiri@...nulli.us> wrote:
>>> +int tcf_block_get(struct tcf_block **p_block,
>>> + struct tcf_proto __rcu **p_filter_chain)
>>> +{
>>> + struct tcf_block *block = kzalloc(sizeof(*block), GFP_KERNEL);
>>> +
>>> + if (!block)
>>> + return -ENOMEM;
>>> + block->p_filter_chain = p_filter_chain;
>>> + *p_block = block;
>>> + return 0;
>>> +}
>>> +EXPORT_SYMBOL(tcf_block_get);
>>
>>
>> XXX_get() is usually for refcnt'ing, here you only allocate
>> a block, so please rename it to tcf_block_alloc().
>
> Later in the series he adds refcounting to these objects.
>
> He explained this to Jamal too.
I have read all patches, unless I miss something, block itself
is not refcn'ted, only chains are, so it makes no sense to get
a block, right?
Powered by blists - more mailing lists