lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20170604.161235.2303882939513535289.davem@davemloft.net>
Date:   Sun, 04 Jun 2017 16:12:35 -0400 (EDT)
From:   David Miller <davem@...emloft.net>
To:     pshelar@....org
Cc:     zhangshengju@...s.chinamobile.com, pshelar@...ira.com,
        netdev@...r.kernel.org
Subject: Re: [net-next] openvswitch: add macro MODULE_ALIAS_VPORT_TYPE for
 vport type alias

From: Pravin Shelar <pshelar@....org>
Date: Sat, 3 Jun 2017 22:58:22 -0700

> On Sat, Jun 3, 2017 at 6:47 AM, Zhang Shengju
> <zhangshengju@...s.chinamobile.com> wrote:
>> Add a new macro MODULE_ALIAS_VPORT_TYPE to unify and simplify the
>> declaration of vport type alias, and replace magic numbers with
>> symbolic constants.
>>
>> Signed-off-by: Zhang Shengju <zhangshengju@...s.chinamobile.com>
>> ---
>>  net/openvswitch/vport-geneve.c | 2 +-
>>  net/openvswitch/vport-gre.c    | 2 +-
>>  net/openvswitch/vport-vxlan.c  | 2 +-
>>  net/openvswitch/vport.h        | 3 +++
>>  4 files changed, 6 insertions(+), 3 deletions(-)
>>
>> diff --git a/net/openvswitch/vport-geneve.c b/net/openvswitch/vport-geneve.c
>> index 5aaf3ba..1c068d6 100644
>> --- a/net/openvswitch/vport-geneve.c
>> +++ b/net/openvswitch/vport-geneve.c
>> @@ -141,4 +141,4 @@ static void __exit ovs_geneve_tnl_exit(void)
>>
>>  MODULE_DESCRIPTION("OVS: Geneve switching port");
>>  MODULE_LICENSE("GPL");
>> -MODULE_ALIAS("vport-type-5");
>> +MODULE_ALIAS_VPORT_TYPE(OVS_VPORT_TYPE_GENEVE);
>> diff --git a/net/openvswitch/vport-gre.c b/net/openvswitch/vport-gre.c
>> index 0e72d95..48a5852 100644
>> --- a/net/openvswitch/vport-gre.c
>> +++ b/net/openvswitch/vport-gre.c
>> @@ -113,4 +113,4 @@ static void __exit ovs_gre_tnl_exit(void)
>>
>>  MODULE_DESCRIPTION("OVS: GRE switching port");
>>  MODULE_LICENSE("GPL");
>> -MODULE_ALIAS("vport-type-3");
>> +MODULE_ALIAS_VPORT_TYPE(OVS_VPORT_TYPE_GRE);
> 
> This is user visible change. For example this is changing the gre
> module alias from "vport-type-3" to "vport-type-OVS_VPORT_TYPE_GRE".
> This could break userspace application.

Agreed, you really can't do this.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ