[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20170616.150246.2299597096137479184.davem@davemloft.net>
Date: Fri, 16 Jun 2017 15:02:46 -0400 (EDT)
From: David Miller <davem@...emloft.net>
To: tracywwnj@...il.com
Cc: netdev@...r.kernel.org, edumazet@...gle.com, kafai@...com,
weiwan@...gle.com
Subject: Re: [PATCH net-next 02/21] udp: call dst_hold_safe() in
udp_sk_rx_set_dst()
From: Wei Wang <tracywwnj@...il.com>
Date: Fri, 16 Jun 2017 10:47:25 -0700
> + if (dst)
> + /* set noref for now.
> + * any place which wants to hold dst has to call
> + * dst_hold_safe()
> + */
> + skb_dst_set_noref(skb, dst);
You must enclose the code in curly braces if you want to put a comment
in this one-line basic block of the 'if' statement.
Otherwise it's hard to read.
Likewise for the other similar change in this file.
THanks.
Powered by blists - more mailing lists