lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 21 Jun 2017 16:22:42 +0300
From:   Michal Kalderon <Michal.Kalderon@...ium.com>
To:     <davem@...emloft.net>, <netdev@...r.kernel.org>
CC:     <linux-rdma@...r.kernel.org>, <Ram.Amrani@...ium.com>,
        <Ariel.Elior@...ium.com>,
        Michal Kalderon <Michal.Kalderon@...ium.com>
Subject: [PATCH net-next 0/4] qed*: File split and rename towards iWARP support

This patch series makes a few more infrastructure changes towards adding
iWARP support. Hopefully this is the last infrastructure change
prior to the iWARP RFC.

Patch #1-3 take care of taking all the common iWARP/RoCE code out of
qed_roce.[ch] and placing it in qed_rdma.[ch]
Patch #4 renames the roce interface file as it is common for
RoCE and iWARP. This patch touches qedr as well.


Michal Kalderon (4):
  qed: Cleanup qed_roce before duplicating it
  qed: Duplicate qed_roce.[ch] to qed_rdma.[ch]
  qed: Split rdma content between qed_rdma and qed_roce
  qed*: Rename qed_roce_if.h to qed_rdma_if.h

 drivers/infiniband/hw/qedr/qedr.h                  |    2 +-
 drivers/infiniband/hw/qedr/qedr_cm.c               |    2 +-
 drivers/net/ethernet/qlogic/qed/Makefile           |    2 +-
 drivers/net/ethernet/qlogic/qed/qed_dcbx.c         |    2 +-
 drivers/net/ethernet/qlogic/qed/qed_dev.c          |    2 +-
 drivers/net/ethernet/qlogic/qed/qed_ll2.c          |    2 +-
 drivers/net/ethernet/qlogic/qed/qed_rdma.c         | 1722 ++++++++++++++++++++
 drivers/net/ethernet/qlogic/qed/qed_rdma.h         |  201 +++
 drivers/net/ethernet/qlogic/qed/qed_roce.c         | 1711 +------------------
 drivers/net/ethernet/qlogic/qed/qed_roce.h         |  151 +-
 drivers/net/ethernet/qlogic/qed/qed_spq.c          |    2 +-
 include/linux/qed/{qed_roce_if.h => qed_rdma_if.h} |    4 +-
 12 files changed, 1963 insertions(+), 1840 deletions(-)
 create mode 100644 drivers/net/ethernet/qlogic/qed/qed_rdma.c
 create mode 100644 drivers/net/ethernet/qlogic/qed/qed_rdma.h
 rename include/linux/qed/{qed_roce_if.h => qed_rdma_if.h} (99%)

-- 
1.8.3.1

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ