[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20170918.211908.2152170523885516973.davem@davemloft.net>
Date: Mon, 18 Sep 2017 21:19:08 -0700 (PDT)
From: David Miller <davem@...emloft.net>
To: tom@...ntonium.net
Cc: netdev@...r.kernel.org, pablo@...filter.org, laforge@...monks.org,
rohit@...ntonium.net
Subject: Re: [PATCH net-next 07/14] gtp: Support encapsulation of IPv6
packets
From: Tom Herbert <tom@...ntonium.net>
Date: Mon, 18 Sep 2017 17:38:57 -0700
> @@ -98,6 +104,7 @@ static void pdp_context_delete(struct pdp_ctx *pctx);
> static inline u32 gtp0_hashfn(u64 tid)
> {
> u32 *tid32 = (u32 *) &tid;
> +
> return jhash_2words(tid32[0], tid32[1], gtp_h_initval);
> }
>
> @@ -111,6 +118,11 @@ static inline u32 ipv4_hashfn(__be32 ip)
> return jhash_1word((__force u32)ip, gtp_h_initval);
> }
>
> +static inline u32 ipv6_hashfn(const struct in6_addr *a)
> +{
> + return __ipv6_addr_jhash(a, gtp_h_initval);
> +}
I know you are just following the pattern of the existing "ipv4_hashfn()" here
but this kind of stuff is not very global namespace friendly. Even simply
adding a "gtp_" prefix to these hash functions would be a lot better.
Powered by blists - more mailing lists