[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20171104130137.GH2024@nanopsycho>
Date: Sat, 4 Nov 2017 14:01:37 +0100
From: Jiri Pirko <jiri@...nulli.us>
To: Daniel Borkmann <daniel@...earbox.net>
Cc: netdev@...r.kernel.org, davem@...emloft.net, nogahf@...lanox.com,
jhs@...atatu.com, xiyou.wangcong@...il.com, mlxsw@...lanox.com,
andrew@...n.ch, vivien.didelot@...oirfairelinux.com,
f.fainelli@...il.com, michael.chan@...adcom.com,
ganeshgr@...lsio.com, saeedm@...lanox.com, matanb@...lanox.com,
leonro@...lanox.com, idosch@...lanox.com,
jakub.kicinski@...ronome.com, simon.horman@...ronome.com,
pieter.jansenvanvuuren@...ronome.com, john.hurley@...ronome.com,
alexander.h.duyck@...el.com, ogerlitz@...lanox.com,
john.fastabend@...il.com, alexei.starovoitov@...il.com
Subject: Re: [patch net-next 3/5] net: sched: introduce block mechanism to
handle netif_keep_dst calls
Sat, Nov 04, 2017 at 11:33:58AM CET, daniel@...earbox.net wrote:
>On 11/04/2017 10:55 AM, Jiri Pirko wrote:
>> Fri, Nov 03, 2017 at 09:15:54PM CET, daniel@...earbox.net wrote:
>> > On 11/03/2017 06:19 PM, Jiri Pirko wrote:
>> > > From: Jiri Pirko <jiri@...lanox.com>
>> > >
>> > > Couple of classifiers call netif_keep_dst directly on q->dev. That is
>> > > not possible to do directly for shared blocke where multiple qdiscs are
>> > > owning the block. So introduce a infrastructure to keep track of the
>> > > block owners in list and use this list to implement block variant of
>> > > netif_keep_dst.
>> > >
>> > > Signed-off-by: Jiri Pirko <jiri@...lanox.com>
>> > [...]
>> > > +struct tcf_block_owner_item {
>> > > + struct list_head list;
>> > > + struct Qdisc *q;
>> > > + enum tcf_block_binder_type binder_type;
>> > > +};
>> > > +
>> > > +static void
>> > > +tcf_block_owner_netif_keep_dst(struct tcf_block *block,
>> > > + struct Qdisc *q,
>> > > + enum tcf_block_binder_type binder_type)
>> > > +{
>> > > + if (block->keep_dst &&
>> > > + binder_type != TCF_BLOCK_BINDER_TYPE_CLSACT_INGRESS)
>> >
>> > Why we need to keep dst on TCF_BLOCK_BINDER_TYPE_CLSACT_EGRESS ?
>> > I presume this enum means sch_handle_egress() ? dst is dropped
>> > later ...
>>
>> This is because of the bpf check:
>> if (fp->dst_needed && !(tp->q->flags & TCQ_F_INGRESS))
>> netif_keep_dst(qdisc_dev(tp->q));
>>
>> I just maintain the same logic here.
>
>No, that's a wrong claim, really ...
>
>clsact in general hooks into the same logic as ingress, so TC_H_CLSACT
>as major needs to reuse TC_H_INGRESS, and qdiscs set up as such set
>TCQ_F_INGRESS as flags. For clsact that means both your block binder
>types for clsact here (ingress/egress).
Ah, indeed, I missed this. I will rename TCQ_F_INGRESS to TCQ_F_CLSACT
as a part of this patchset too.
>
>Please make sure that your other changes don't have similar assumption.
They don't. Thanks for the review!
Powered by blists - more mailing lists