lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Sat, 24 Mar 2018 17:04:50 +0100
From:   Jiri Pirko <>
To:     Andrew Lunn <>
Subject: Re: [patch net-next RFC 00/12] devlink: introduce port flavours and
 common phys_port_name generation

Sat, Mar 24, 2018 at 03:40:02PM CET, wrote:
>> >The hardware and mechanical engineer is free to wire switch ports to
>> >the front panel however they want. That is why we put the netdev name
>> >in device tree.
>> Got it. Hmm, so I think that the port number can be made optional and
>> when it is present, it would be used to generate phys_port_name. If
>> not, perhaps devlink port index could be used instead.
>> So iiuc, you don't really need phys_port_name in dsa, as it provides
>> misleading names, right? Why is it implemented then?
>Hi Jiri
>Isn't the same true for all devices? It is not just DSA devices where
>the hardware engineer is free to wire up the front panel however they
>want, it can happen for any device.

In mlxsw, driver queries the FW to get this info.

Powered by blists - more mailing lists