[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20180403161356.pkbbwvy4im4nfvqc@kafai-mbp.dhcp.thefacebook.com>
Date: Tue, 3 Apr 2018 09:14:14 -0700
From: Martin KaFai Lau <kafai@...com>
To: Alexey Kodanev <alexey.kodanev@...cle.com>
CC: <netdev@...r.kernel.org>, Eric Dumazet <edumazet@...gle.com>,
David Miller <davem@...emloft.net>
Subject: Re: [PATCH net v6 0/4] ipv6: udp: set dst cache for a connected sk
if current not valid
On Tue, Apr 03, 2018 at 03:00:06PM +0300, Alexey Kodanev wrote:
> A new RTF_CACHE route can be created with the socket's dst cache
> update between the below calls in udpv6_sendmsg(), when datagram
> sending results to ICMPV6_PKT_TOOBIG error:
>
> dst = ip6_sk_dst_lookup_flow(...)
> ...
> release_dst:
> if (dst) {
> if (connected) {
> ip6_dst_store(sk, dst)
>
> Therefore, the new socket's dst cache reset to the old one on
> "release_dst:".
>
> The first three patches prepare the code to store dst cache
> with ip6_sk_dst_lookup_flow():
>
> * the first patch adds ip6_sk_dst_store_flow() function with
> commonly used source and destiantion addresses checks using
> the flow information.
>
> * the second patch adds a new argument to ip6_sk_dst_lookup_flow()
> and ability to store dst in the socket's cache. Also, the two
> users of the function are updated without enabling the new
> behavior: pingv6_sendmsg() and udpv6_sendmsg().
>
> * the third patch makes 'connected' variable in udpv6_sendmsg()
> to be consistent with ip6_sk_dst_store_flow(), changes its type
> from int to bool.
>
> The last patch contains the actual fix that removes sk dst cache
> update in the end of udpv6_sendmsg(), and allows to do it in
> ip6_sk_dst_lookup_flow().
Thanks for the patches!
Acked-by: Martin KaFai Lau <kafai@...com>
>
> v6: * use bool type for a new parameter in ip_sk_dst_lookup_flow()
> * add one more patch to convert 'connected' variable in
> udpv6_sendmsg() from int to bool type. If it shouldn't be
> here I will resend it when the net-next is opened.
>
> v5: * relocate ip6_sk_dst_store_flow() to net/ipv6/route.c and
> rename ip6_dst_store_flow() to ip6_sk_dst_store_flow() as
> suggested by Martin
>
> v4: * fix the error in the build of ip_dst_store_flow() reported by
> kbuild test robot due to missing checks for CONFIG_IPV6: add
> new function to ip6_output.c instead of ip6_route.h
> * add 'const' to struct flowi6 in ip6_dst_store_flow()
> * minor commit messages fixes
>
> v3: * instead of moving ip6_dst_store() above udp_v6_send_skb(),
> update socket's dst cache inside ip6_sk_dst_lookup_flow()
> if the current one is invalid
> * the issue not reproduced in 4.1, but starting from 4.2. Add
> one more 'Fixes:' commit that creates new RTF_CACHE route.
> Though, it is also mentioned in the first one
>
> Alexey Kodanev (4):
> ipv6: add a wrapper for ip6_dst_store() with flowi6 checks
> ipv6: allow to cache dst for a connected sk in ip6_sk_dst_lookup_flow()
> ipv6: udp: convert 'connected' to bool type in udpv6_sendmsg()
> ipv6: udp: set dst cache for a connected sk if current not valid
>
> include/net/ip6_route.h | 3 +++
> include/net/ipv6.h | 3 ++-
> net/ipv6/datagram.c | 9 +--------
> net/ipv6/ip6_output.c | 15 ++++++++++++---
> net/ipv6/ping.c | 2 +-
> net/ipv6/route.c | 17 +++++++++++++++++
> net/ipv6/udp.c | 31 +++++++------------------------
> 7 files changed, 43 insertions(+), 37 deletions(-)
>
> --
> 1.8.3.1
>
Powered by blists - more mailing lists