[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20180418223906.16650-1-dsahern@gmail.com>
Date: Wed, 18 Apr 2018 15:38:58 -0700
From: David Ahern <dsahern@...il.com>
To: netdev@...r.kernel.org
Cc: davem@...emloft.net, idosch@...sch.org, roopa@...ulusnetworks.com,
eric.dumazet@...il.com, weiwan@...gle.com, kafai@...com,
yoshfuji@...ux-ipv6.org, David Ahern <dsahern@...il.com>
Subject: [PATCH net-next 0/8] net/ipv6: followup to fib6_info change
Followup to fib change for IPv6.
First 2 patches rename fib6_info struct elements to match its name,
and rename addrconf_dst_alloc to match what it returns.
Patches 3-7 refactor the code to remove the need for fib6_idev reducing
fib6_info by another 8 bytes to 200 bytes.
Patch 8 fixes the gfp flags argument to addrconf_prefix_route in a
couple of places.
David Ahern (8):
net/ipv6: Rename fib6_info struct elements
net/ipv6: Rename addrconf_dst_alloc
net/ipv6: Remove aca_idev
net/ipv6: Remove unnecessary checks on fib6_idev
net/ipv6: Change ip6_route_get_saddr to get dev from route
net/ipv6: Remove compare of fib6_idev from rt6_duplicate_nexthop
net/ipv6: Remove fib6_idev
net/ipv6: Fix gfp_flags arg to addrconf_prefix_route
.../net/ethernet/mellanox/mlxsw/spectrum_router.c | 56 ++--
include/net/if_inet6.h | 1 -
include/net/ip6_fib.h | 42 +--
include/net/ip6_route.h | 34 +-
net/ipv6/addrconf.c | 59 ++--
net/ipv6/anycast.c | 24 +-
net/ipv6/ip6_fib.c | 168 +++++-----
net/ipv6/ndisc.c | 2 +-
net/ipv6/route.c | 358 +++++++++++----------
9 files changed, 375 insertions(+), 369 deletions(-)
--
2.11.0
Powered by blists - more mailing lists