lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:   Sat, 23 Feb 2019 08:50:55 -0800
From:   Stephen Hemminger <stephen@...workplumber.org>
To:     netdev@...r.kernel.org
Subject: Fw: [Bug 202651] New: Regression in atlantic.ko between 4.20 and
 5.00-rc4 for Aquantia NIC 1d6a:87b1



Begin forwarded message:

Date: Sat, 23 Feb 2019 09:01:29 +0000
From: bugzilla-daemon@...zilla.kernel.org
To: stephen@...workplumber.org
Subject: [Bug 202651] New: Regression in atlantic.ko between 4.20 and 5.00-rc4 for Aquantia NIC 1d6a:87b1


https://bugzilla.kernel.org/show_bug.cgi?id=202651

            Bug ID: 202651
           Summary: Regression in atlantic.ko between 4.20 and 5.00-rc4
                    for Aquantia NIC 1d6a:87b1
           Product: Networking
           Version: 2.5
    Kernel Version: 5.00-rc4
          Hardware: All
                OS: Linux
              Tree: Mainline
            Status: NEW
          Severity: high
          Priority: P1
         Component: IPV4
          Assignee: stephen@...workplumber.org
          Reporter: nicholas.johnson@...look.com.au
        Regression: No

Hardware Details:
==============================================================================

VEN:DEV = 1d6a:87b1 "Aquantia Corp. AQC107 NBase-T/IEEE 802.3bz Ethernet
Controller [AQtion]" Specifically, this is the newer AQC107S with "S"
meaning "Secure" and the company could never elaborate on how it is more
secure than the plain AQC107 (different VEN:DEV). This chip is inside
the Promise SANLink3 N1 Thunderbolt 3 10GbE adapter.


Severity:
==============================================================================

Marked high severity because it directly impacts user experience (cannot
get the network to come up on the adapter).


Back Story and Problem:
==============================================================================

In 5.00-rc4, on my Ubuntu desktop I have had extreme problems getting
the connection up (borderline impossible). If I did manage (after
messing with systemd *a lot*) then I got a dodgy connection with a lot
of DNS resolution problems. At first I blamed it on my desktop which had
a habit of corrupting the SSD partition tables on a regular basis, and
hence I assumed that systemd was corrupted or something.

Recently, I tried on my laptop with Arch Linux and 5.00-rc4 and it had
the exact same problem. It does not matter if you manually assign the 
IPv4 address, or use DHCPv4.

Just now, on my laptop, I booted into 4.20.3-arch1-1-ARCH kernel from
Arch Linux and it worked straight away.


Expected behaviour:
==============================================================================

NetworkManager (or any tool) should bring the link up successfully.


Reproduction:
==============================================================================

Should be reproducible with a 5.00-rc4 kernel and the 1d6a:87b1 NIC. I
have no way of testing if other Aquantia devices are affected - I do not
own any others. I am using Ubuntu and Arch (both the very latest) and I
just cannot get NetworkManager to bring up the connection with 5.00-rc4
(happens effortlessly with 4.20 kernel). If you want NetworkManager to
manage the adapter, you may need to use the
10-globally-managed-devices.conf fix, depending on the version.


Technical Notes:
==============================================================================

It is hard to tell, but my gut tells me that it is IPv4-related. That
would explain why some sites could work. I have a native IPv6 service
from my ISP. The "ifconfig" command shows IPv6 addresses assigned, but
it is very difficult to get a DHCPv4-assigned address on the adapter.

A couple of times I did manage to get the adapter up in 5.00-rc4 with a
lot of messing around, and the resulting internet connection was
unreliable and unstable. DNS resolution seemed to be a big part of the
problem.

All BARs are assigned correctly. Other than that, dmesg does not give
anything interesting that I can tell, so if you want some debug logs
from somewhere then please tell me what you want and how I should do it.

There are a fair few lines of diff between 4.20 and 5.00-rc4 so there is
likely an oopsie in there.


Always Remembering My Manners:
==============================================================================

Thank you for reading my bug report!


Why Are Web Developers So Annoying?
==============================================================================

The preview removes all my newlines and nice formatting which I did so have fun
trying to read this big blob of unformatted text.

-- 
You are receiving this mail because:
You are the assignee for the bug.

Powered by blists - more mailing lists