lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 28 Feb 2019 15:27:44 +0100
From:   Michal Vokáč <michal.vokac@...ft.com>
To:     Heiner Kallweit <hkallweit1@...il.com>,
        Andrew Lunn <andrew@...n.ch>
Cc:     Vinod Koul <vkoul@...nel.org>,
        "David S. Miller" <davem@...emloft.net>,
        Florian Fainelli <f.fainelli@...il.com>, netdev@...r.kernel.org
Subject: Re: [RFC] net: dsa: qca8k: CPU port broken with commit 5502b218e001
 ("net: phy: use phy_resolve_aneg_linkmode in genphy_read_status")

On 26. 02. 19 8:33, Heiner Kallweit wrote:
> On 20.02.2019 16:02, Michal Vokáč wrote:
>> Hi,
>>
>> Another issue in a row with networking on imx6dl-yapp4 platform [1]
>> that uses QCA8334 Ethernet switch.
>>
>> Very recently, with Vinod and Andrew, we solved an issue with
>> RGMII_ID mode by patch[2][3]. I tested those with next-20190215
>> and it worked just fine.
>>
>> The patch[2] was merged into next-20190220 so I tested the latest version.
>> Now the cpu port does not work again. I tracked it down to this commit
>> 5502b218e001 ("net: phy: use phy_resolve_aneg_linkmode in
>> genphy_read_status") [4]
>>
>> If I revert the offending commit, cpu port works fine. I suspect the
>> problem is on the qca8k driver side but I am not really sure.
>> AFAICT autonegotiation is not available on the QCA833x cpu port (MAC0).
>>
>> Any ideas what may be the root cause of the problem?
>>
> Hi Michal,
> 
> I faced the same issue on a system with  Marvell switch.
> Should be fixed with 0f3b1cf23f0e ("net: phy: fix reading fixed phy status").
> This patch is in net-next currently and should show up in linux-next today.

Hello Heiner,

sorry for the delay. I spent some time debugging the issue since your first
response and then got distracted by sickness and other responsibilities.

I can confirm that commit 0f3b1cf23f0e ("net: phy: fix reading fixed phy
status") fixes this issue for me. I tested it with next-20190222 though
as the latest linux-next breaks the networking for me again in a different
way. I have no more details yet but I will create a new thread for that
once I have something more tangible.

Thank you,
Michal

>> [1] https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/commit/?id=87489ec3a77f3e01bcf0d46e353ae7112ec8c4f0
>> [2] https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/commit/?id=a968b5e9d5879f9535d6099505f9e14abcafb623
>> [3] https://lore.kernel.org/patchwork/patch/1043817/
>> [4] https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/commit/?id=5502b218e001

Powered by blists - more mailing lists