[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <acc3f1ce-29e5-19fb-b011-67f68f80cd88@gmail.com>
Date: Tue, 19 Mar 2019 06:54:02 -0700
From: Eric Dumazet <eric.dumazet@...il.com>
To: Paolo Abeni <pabeni@...hat.com>, netdev@...r.kernel.org
Cc: Mike Marciniszyn <mike.marciniszyn@...el.com>,
Doug Ledford <dledford@...hat.com>,
Jay Vosburgh <j.vosburgh@...il.com>,
"David S. Miller" <davem@...emloft.net>,
Saeed Bishara <saeedb@...zon.com>,
Florian Fainelli <f.fainelli@...il.com>,
Ariel Elior <aelior@...vell.com>,
Vishal Kulkarni <vishal@...lsio.com>,
Jeff Kirsher <jeffrey.t.kirsher@...el.com>,
Salil Mehta <salil.mehta@...wei.com>,
Tariq Toukan <tariqt@...lanox.com>,
"K. Y. Srinivasan" <kys@...rosoft.com>,
Kalle Valo <kvalo@...eaurora.org>,
Wei Liu <wei.liu2@...rix.com>,
Johannes Berg <johannes@...solutions.net>,
Willem de Bruijn <willemdebruijn.kernel@...il.com>
Subject: Re: [PATCH net-next 1/2] packet: rework packet_pick_tx_queue() to use
common code selection
On 03/19/2019 06:25 AM, Paolo Abeni wrote:
> +u16 __netdev_pick_tx(struct net_device *dev, struct sk_buff *skb,
> + struct net_device *sb_dev)
> {
> struct sock *sk = skb->sk;
> int queue_index = sk_tx_queue_get(sk);
> @@ -3729,6 +3729,7 @@ static u16 __netdev_pick_tx(struct net_device *dev, struct sk_buff *skb,
>
> return queue_index;
> }
> +EXPORT_SYMBOL(__netdev_pick_tx);
>
I would rather rename this function, now it is going to be used from many drivers.
Maybe the internal core-networking should be renamed as core_netdev_pick_tx()
and the 'fallback' would be named netdev_pick_tx()
Powered by blists - more mailing lists