[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <20190425164533.8BD0160736@smtp.codeaurora.org>
Date: Thu, 25 Apr 2019 16:45:33 +0000 (UTC)
From: Kalle Valo <kvalo@...eaurora.org>
To: "Gustavo A. R. Silva" <gustavo@...eddedor.com>
Cc: Amitkumar Karwar <amitkarwar@...il.com>,
Nishant Sarmukadam <nishants@...vell.com>,
Ganapathi Bhat <gbhat@...vell.com>,
Xinming Hu <huxinming820@...il.com>,
"David S. Miller" <davem@...emloft.net>,
linux-wireless@...r.kernel.org, netdev@...r.kernel.org,
linux-kernel@...r.kernel.org,
"Gustavo A. R. Silva" <gustavo@...eddedor.com>
Subject: Re: [PATCH][next] mwifiex: use struct_size() in kzalloc()
"Gustavo A. R. Silva" <gustavo@...eddedor.com> wrote:
> One of the more common cases of allocation size calculations is finding
> the size of a structure that has a zero-sized array at the end, along
> with memory for some number of elements for that array. For example:
>
> struct foo {
> int stuff;
> struct boo entry[];
> };
>
> size = sizeof(struct foo) + count * sizeof(struct boo);
> instance = kzalloc(size, GFP_KERNEL)
>
> Instead of leaving these open-coded and prone to type mistakes, we can
> now use the new struct_size() helper:
>
> instance = kzalloc(struct_size(instance, entry, count), GFP_KERNEL)
>
> Notice that, in this case, variable regd_size is not necessary,
> hence it is removed.
>
> This code was detected with the help of Coccinelle.
>
> Signed-off-by: Gustavo A. R. Silva <gustavo@...eddedor.com>
Patch applied to wireless-drivers-next.git, thanks.
ae187ba91541 mwifiex: use struct_size() in kzalloc()
--
https://patchwork.kernel.org/patch/10884249/
https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches
Powered by blists - more mailing lists