[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAB-e3NSidgz8gLRTL796A0DyRVePPjVDpSC6=gSA4hH8q6VqvQ@mail.gmail.com>
Date: Thu, 30 May 2019 15:34:10 -0700
From: Luke Nelson <luke.r.nels@...il.com>
To: Song Liu <liu.song.a23@...il.com>
Cc: Xi Wang <xi.wang@...il.com>,
Björn Töpel <bjorn.topel@...il.com>,
Palmer Dabbelt <palmer@...ive.com>,
Albert Ou <aou@...s.berkeley.edu>,
Alexei Starovoitov <ast@...nel.org>,
Daniel Borkmann <daniel@...earbox.net>,
Martin KaFai Lau <kafai@...com>,
Song Liu <songliubraving@...com>, Yonghong Song <yhs@...com>,
Networking <netdev@...r.kernel.org>,
linux-riscv@...ts.infradead.org, bpf <bpf@...r.kernel.org>,
open list <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 1/2] bpf, riscv: fix bugs in JIT for 32-bit ALU operations
On Thu, May 30, 2019 at 1:53 PM Song Liu <liu.song.a23@...il.com> wrote:
>
> This is a little messy. How about we introduce some helper function
> like:
>
> /* please find a better name... */
> emit_32_or_64(bool is64, const u32 insn_32, const u32 inst_64, struct
> rv_jit_context *ctx)
> {
> if (is64)
> emit(insn_64, ctx);
> else {
> emit(insn_32, ctx);
> rd = xxxx;
> emit_zext_32(rd, ctx);
> }
> }
This same check is used throughout the file, maybe clean it up in a
separate patch?
Powered by blists - more mailing lists