[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAEf4BzZsmH+4A0dADeXYUDqeEK9N_-PVqzHW_=vPytjEX1hqTA@mail.gmail.com>
Date: Fri, 21 Jun 2019 12:13:56 -0700
From: Andrii Nakryiko <andrii.nakryiko@...il.com>
To: Eelco Chaudron <echaudro@...hat.com>
Cc: Networking <netdev@...r.kernel.org>,
Alexei Starovoitov <ast@...nel.org>,
Daniel Borkmann <daniel@...earbox.net>,
Martin Lau <kafai@...com>, Song Liu <songliubraving@...com>,
Yonghong Song <yhs@...com>
Subject: Re: [PATCH bpf-next] libbpf: add xsk_ring_prod__free() function
On Fri, Jun 21, 2019 at 8:26 AM Eelco Chaudron <echaudro@...hat.com> wrote:
>
> When an AF_XDP application received X packets, it does not mean X
> frames can be stuffed into the producer ring. To make it easier for
> AF_XDP applications this API allows them to check how many frames can
> be added into the ring.
>
> Signed-off-by: Eelco Chaudron <echaudro@...hat.com>
> ---
> tools/lib/bpf/xsk.h | 6 ++++++
> 1 file changed, 6 insertions(+)
>
> diff --git a/tools/lib/bpf/xsk.h b/tools/lib/bpf/xsk.h
> index 82ea71a0f3ec..86f3d485e957 100644
> --- a/tools/lib/bpf/xsk.h
> +++ b/tools/lib/bpf/xsk.h
> @@ -95,6 +95,12 @@ static inline __u32 xsk_prod_nb_free(struct xsk_ring_prod *r, __u32 nb)
> return r->cached_cons - r->cached_prod;
> }
>
> +static inline __u32 xsk_ring_prod__free(struct xsk_ring_prod *r)
This is a very bad name choice. __free is used for functions that free
memory and resources. One function below I see avail is used in the
name, why not xsk_ring_prog__avail?
> +{
> + r->cached_cons = *r->consumer + r->size;
> + return r->cached_cons - r->cached_prod;
> +}
> +
> static inline __u32 xsk_cons_nb_avail(struct xsk_ring_cons *r, __u32 nb)
> {
> __u32 entries = r->cached_prod - r->cached_cons;
> --
> 2.20.1
>
Powered by blists - more mailing lists