[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <271605C0-55F6-45EA-A169-298B62911BEC@redhat.com>
Date: Tue, 25 Jun 2019 09:58:47 +0200
From: "Eelco Chaudron" <echaudro@...hat.com>
To: "Andrii Nakryiko" <andrii.nakryiko@...il.com>
Cc: "Karlsson, Magnus" <magnus.karlsson@...el.com>,
Networking <netdev@...r.kernel.org>,
"Alexei Starovoitov" <ast@...nel.org>,
"Daniel Borkmann" <daniel@...earbox.net>,
"Martin Lau" <kafai@...com>, "Song Liu" <songliubraving@...com>,
"Yonghong Song" <yhs@...com>
Subject: Re: [PATCH bpf-next] libbpf: add xsk_ring_prod__free() function
On 24 Jun 2019, at 18:42, Andrii Nakryiko wrote:
> On Mon, Jun 24, 2019 at 2:37 AM Eelco Chaudron <echaudro@...hat.com>
> wrote:
>>
>>
>>
>> On 21 Jun 2019, at 21:13, Andrii Nakryiko wrote:
>>
>>> On Fri, Jun 21, 2019 at 8:26 AM Eelco Chaudron <echaudro@...hat.com>
>>> wrote:
>>>>
>>>> When an AF_XDP application received X packets, it does not mean X
>>>> frames can be stuffed into the producer ring. To make it easier for
>>>> AF_XDP applications this API allows them to check how many frames
>>>> can
>>>> be added into the ring.
>>>>
>>>> Signed-off-by: Eelco Chaudron <echaudro@...hat.com>
>>>> ---
>>>> tools/lib/bpf/xsk.h | 6 ++++++
>>>> 1 file changed, 6 insertions(+)
>>>>
>>>> diff --git a/tools/lib/bpf/xsk.h b/tools/lib/bpf/xsk.h
>>>> index 82ea71a0f3ec..86f3d485e957 100644
>>>> --- a/tools/lib/bpf/xsk.h
>>>> +++ b/tools/lib/bpf/xsk.h
>>>> @@ -95,6 +95,12 @@ static inline __u32 xsk_prod_nb_free(struct
>>>> xsk_ring_prod *r, __u32 nb)
>>>> return r->cached_cons - r->cached_prod;
>>>> }
>>>>
>>>> +static inline __u32 xsk_ring_prod__free(struct xsk_ring_prod *r)
>>>
>>> This is a very bad name choice. __free is used for functions that
>>> free
>>> memory and resources. One function below I see avail is used in the
>>> name, why not xsk_ring_prog__avail?
>>
>> Must agree that free sound like you are freeing entries… However, I
>> just kept the naming already in the API/file (see above,
>> xsk_prod_nb_free()).
>> Reading the code there is a difference as xx_avail() means available
>> filled entries, where xx_free() means available free entries.
>>
>> So I could rename it to xsk_ring_prod__nb_free() maybe?
>
> I'm fine with __nb_free, yes. Thanks!
Ok, will rework the patch and use xsk_ring_prod__nb_free(). Will also
take Magnus suggestion into account, and create a cached version (and
use it internally).
>>
>> Forgot to include Magnus in the email, so copied him in, for some
>> comments.
>>
>>>> +{
>>>> + r->cached_cons = *r->consumer + r->size;
>>>> + return r->cached_cons - r->cached_prod;
>>>> +}
>>>> +
>>>> static inline __u32 xsk_cons_nb_avail(struct xsk_ring_cons *r,
>>>> __u32
>>>> nb)
>>>> {
>>>> __u32 entries = r->cached_prod - r->cached_cons;
>>>> --
>>>> 2.20.1
>>>>
Powered by blists - more mailing lists