lists.openwall.net | lists / announce owl-users owl-dev john-users john-dev passwdqc-users yescrypt popa3d-users / oss-security kernel-hardening musl sabotage tlsify passwords / crypt-dev xvendor / Bugtraq Full-Disclosure linux-kernel linux-netdev linux-ext4 linux-hardening PHC | |
Open Source and information security mailing list archives
| ||
|
Date: Mon, 12 Aug 2019 10:06:40 +0100 From: Andrew Murray <andrew.murray@....com> To: Denis Efremov <efremov@...ux.com> Cc: Bjorn Helgaas <bhelgaas@...gle.com>, Sebastian Ott <sebott@...ux.ibm.com>, Gerald Schaefer <gerald.schaefer@...ibm.com>, "H. Peter Anvin" <hpa@...or.com>, Giuseppe Cavallaro <peppe.cavallaro@...com>, Alexandre Torgue <alexandre.torgue@...com>, Matt Porter <mporter@...nel.crashing.org>, Alexandre Bounine <alex.bou9@...il.com>, Peter Jones <pjones@...hat.com>, Bartlomiej Zolnierkiewicz <b.zolnierkie@...sung.com>, Cornelia Huck <cohuck@...hat.com>, Alex Williamson <alex.williamson@...hat.com>, kvm@...r.kernel.org, linux-fbdev@...r.kernel.org, netdev@...r.kernel.org, x86@...nel.org, linux-s390@...r.kernel.org, linux-pci@...r.kernel.org, linux-kernel@...r.kernel.org Subject: Re: [PATCH 0/7] Add definition for the number of standard PCI BARs On Sun, Aug 11, 2019 at 06:07:55PM +0300, Denis Efremov wrote: > Code that iterates over all standard PCI BARs typically uses > PCI_STD_RESOURCE_END, but this is error-prone because it requires > "i <= PCI_STD_RESOURCE_END" rather than something like > "i < PCI_STD_NUM_BARS". We could add such a definition and use it the same > way PCI_SRIOV_NUM_BARS is used. There is already the definition > PCI_BAR_COUNT for s390 only. Thus, this patchset introduces it globally. > > The patch is splitted into 7 parts for different drivers/subsystems for > easy readability. > > Denis Efremov (7): > PCI: Add define for the number of standard PCI BARs > s390/pci: Replace PCI_BAR_COUNT with PCI_STD_NUM_BARS > x86/PCI: Use PCI_STD_NUM_BARS in loops instead of PCI_STD_RESOURCE_END > PCI/net: Use PCI_STD_NUM_BARS in loops instead of PCI_STD_RESOURCE_END > rapidio/tsi721: use PCI_STD_NUM_BARS in loops instead of > PCI_STD_RESOURCE_END > efifb: Use PCI_STD_NUM_BARS in loops instead of PCI_STD_RESOURCE_END > vfio_pci: Use PCI_STD_NUM_BARS in loops instead of > PCI_STD_RESOURCE_END > > arch/s390/include/asm/pci.h | 5 +---- > arch/s390/include/asm/pci_clp.h | 6 +++--- > arch/s390/pci/pci.c | 16 ++++++++-------- > arch/s390/pci/pci_clp.c | 6 +++--- > arch/x86/pci/common.c | 2 +- > drivers/net/ethernet/stmicro/stmmac/stmmac_pci.c | 4 ++-- > drivers/net/ethernet/synopsys/dwc-xlgmac-pci.c | 2 +- > drivers/pci/quirks.c | 2 +- > drivers/rapidio/devices/tsi721.c | 2 +- > drivers/vfio/pci/vfio_pci.c | 4 ++-- > drivers/vfio/pci/vfio_pci_config.c | 2 +- > drivers/vfio/pci/vfio_pci_private.h | 4 ++-- > drivers/video/fbdev/efifb.c | 2 +- > include/linux/pci.h | 2 +- > include/uapi/linux/pci_regs.h | 1 + Hi Denis, You could also fix up a few cases where the number of BARs is hard coded in loops, e.g. drivers/pci/controller/pci-hyperv.c - look for uses of probed_bar in loops drivers/pci/pci.c - pci_release_selected_regions and __pci_request_selected_regions drivers/pci/quirks.c - quirk_alder_ioapic Thanks, Andrew Murray > 15 files changed, 29 insertions(+), 31 deletions(-) > > -- > 2.21.0 >
Powered by blists - more mailing lists