lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 17 Sep 2019 17:46:13 -0600
From:   David Ahern <>
To:     Jiri Pirko <>
Subject: Re: [patch iproute2-next v2] devlink: add reload failed indication

On 9/17/19 12:36 PM, Jiri Pirko wrote:
> Tue, Sep 17, 2019 at 06:46:31PM CEST, wrote:
>> On 9/16/19 3:44 AM, Jiri Pirko wrote:
>>> From: Jiri Pirko <>
>>> Add indication about previous failed devlink reload.
>>> Example outputs:
>>> $ devlink dev
>>> netdevsim/netdevsim10: reload_failed true
>> odd output to user. Why not just "reload failed"?
> Well it is common to have "name value". The extra space would seem
> confusing for the reader..
> Also it is common to have "_" instead of space for the output in cases
> like this.

I am not understanding your point.

"reload failed" is still a name/value pair. It is short and to the point
as to what it indicates. There is no need for the name in the uapi (ie.,
the name of the netlink attribute) to be dumped here.

Powered by blists - more mailing lists