lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 7 Nov 2019 15:07:39 -0800
From:   Alexei Starovoitov <alexei.starovoitov@...il.com>
To:     Song Liu <songliubraving@...com>
Cc:     Alexei Starovoitov <ast@...nel.org>,
        David Miller <davem@...emloft.net>,
        "daniel@...earbox.net" <daniel@...earbox.net>,
        "x86@...nel.org" <x86@...nel.org>,
        "netdev@...r.kernel.org" <netdev@...r.kernel.org>,
        "bpf@...r.kernel.org" <bpf@...r.kernel.org>,
        Kernel Team <Kernel-team@...com>
Subject: Re: [PATCH v2 bpf-next 04/17] libbpf: Add support to attach to
 fentry/fexit tracing progs

On Thu, Nov 07, 2019 at 10:51:41PM +0000, Song Liu wrote:
> 
> 
> > On Nov 6, 2019, at 9:46 PM, Alexei Starovoitov <ast@...nel.org> wrote:
> > 
> > Teach libbpf to recognize tracing programs types and attach them to
> > fentry/fexit.
> > 
> > Signed-off-by: Alexei Starovoitov <ast@...nel.org>
> 
> Acked-by: Song Liu <songliubraving@...com>
> 
> With nit below:
> 
> > ---
> > tools/include/uapi/linux/bpf.h |  2 ++
> > tools/lib/bpf/libbpf.c         | 61 +++++++++++++++++++++++++++++-----
> > tools/lib/bpf/libbpf.h         |  5 +++
> > tools/lib/bpf/libbpf.map       |  2 ++
> > 4 files changed, 61 insertions(+), 9 deletions(-)
> > 
> 
> [...]
> 
> > 
> > /* Accessors of bpf_program */
> > struct bpf_program;
> > @@ -248,6 +251,8 @@ LIBBPF_API struct bpf_link *
> > bpf_program__attach_raw_tracepoint(struct bpf_program *prog,
> > 				   const char *tp_name);
> > 
> > +LIBBPF_API struct bpf_link *
> > +bpf_program__attach_trace(struct bpf_program *prog);
> > struct bpf_insn;
> 
> attach_trace is not very clear. I guess we cannot call it 
> attach_ftrace? Maybe we call it attach_fentry and attach_fexit
> (two names pointing to same function)? 

bpf_program__attach_trace() can attach all BPF_PROG_TYPE_TRACING.
Which today are:
        BPF_TRACE_RAW_TP,
        BPF_TRACE_FENTRY,
        BPF_TRACE_FEXIT,
There will be more BPF_TRACE_* enum bpf_attach_type in the future.
I considered naming it bpf_program__attach_tracing(), but it's uglier
and longer.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ