lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 18 Nov 2019 16:21:39 -0500
From:   Aaron Conole <aconole@...hat.com>
To:     Marcelo Ricardo Leitner <marcelo.leitner@...il.com>
Cc:     netdev@...r.kernel.org, Pravin B Shelar <pshelar@....org>,
        "David S . Miller" <davem@...emloft.net>,
        Jamal Hadi Salim <jhs@...atatu.com>,
        Cong Wang <xiyou.wangcong@...il.com>,
        Jiri Pirko <jiri@...nulli.us>, dev@...nvswitch.org,
        linux-kernel@...r.kernel.org, paulb@...lanox.com
Subject: Re: [PATCH net 2/2] act_ct: support asymmetric conntrack

Marcelo Ricardo Leitner <marcelo.leitner@...il.com> writes:

> On Fri, Nov 08, 2019 at 04:07:14PM -0500, Aaron Conole wrote:
>> The act_ct TC module shares a common conntrack and NAT infrastructure
>> exposed via netfilter.  It's possible that a packet needs both SNAT and
>> DNAT manipulation, due to e.g. tuple collision.  Netfilter can support
>> this because it runs through the NAT table twice - once on ingress and
>> again after egress.  The act_ct action doesn't have such capability.
>> 
>> Like netfilter hook infrastructure, we should run through NAT twice to
>> keep the symmetry.
>> 
>> Fixes: b57dc7c13ea9 ("net/sched: Introduce action ct")
>> 
>> Signed-off-by: Aaron Conole <aconole@...hat.com>
>> ---
>>  net/sched/act_ct.c | 13 ++++++++++++-
>>  1 file changed, 12 insertions(+), 1 deletion(-)
>> 
>> diff --git a/net/sched/act_ct.c b/net/sched/act_ct.c
>> index fcc46025e790..f3232a00970f 100644
>> --- a/net/sched/act_ct.c
>> +++ b/net/sched/act_ct.c
>> @@ -329,6 +329,7 @@ static int tcf_ct_act_nat(struct sk_buff *skb,
>>  			  bool commit)
>>  {
>>  #if IS_ENABLED(CONFIG_NF_NAT)
>> +	int err;
>>  	enum nf_nat_manip_type maniptype;
>>  
>>  	if (!(ct_action & TCA_CT_ACT_NAT))
>> @@ -359,7 +360,17 @@ static int tcf_ct_act_nat(struct sk_buff *skb,
>>  		return NF_ACCEPT;
>>  	}
>>  
>> -	return ct_nat_execute(skb, ct, ctinfo, range, maniptype);
>> +	err = ct_nat_execute(skb, ct, ctinfo, range, maniptype);
>> +	if (err == NF_ACCEPT &&
>> +	    ct->status & IPS_SRC_NAT && ct->status & IPS_DST_NAT) {
>> +		if (maniptype == NF_NAT_MANIP_SRC)
>> +			maniptype = NF_NAT_MANIP_DST;
>> +		else
>> +			maniptype = NF_NAT_MANIP_SRC;
>> +
>> +		err = ct_nat_execute(skb, ct, ctinfo, range, maniptype);
>> +	}
>
> I keep thinking about this and I'm not entirely convinced that this
> shouldn't be simpler. More like:
>
> if (DNAT)
> 	DNAT
> if (SNAT)
> 	SNAT
>
> So it always does DNAT before SNAT, similarly to what iptables would
> do on PRE/POSTROUTING chains.

I can rewrite the whole function, but I wanted to start with the smaller
fix that worked.  I also think it needs more testing then (since it's
something of a rewrite of the function).

I guess it's not too important - do you think it gives any readability
to do it this way?  If so, I can respin the patch changing it like you
describe.

>> +	return err;
>>  #else
>>  	return NF_ACCEPT;
>>  #endif
>> -- 
>> 2.21.0
>> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ