[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <cover.1575517685.git.ethercflow@gmail.com>
Date: Wed, 4 Dec 2019 23:20:34 -0500
From: Wenbo Zhang <ethercflow@...il.com>
To: bpf@...r.kernel.org
Cc: ast@...nel.org, daniel@...earbox.net, yhs@...com,
andrii.nakryiko@...il.com, netdev@...r.kernel.org
Subject: [PATCH bpf-next v11 0/2] bpf: adding get_file_path helper
This patch series introduce a bpf helper that can be used to map a file
descriptor to a pathname.
This requirement is mainly discussed here:
https://github.com/iovisor/bcc/issues/237
This implementation supports both local and mountable pseudo file systems,
and ensure we're in user context which is safe for this helper to run.
Changes since v10:
* fix missing fput
Changes since v9:
* Associate help patch with its selftests patch to this series
* Refactor selftests code for further simplification
Changes since v8:
* format helper description
Changes since v7:
* Use fget_raw instead of fdget_raw, as fdget_raw is only used inside fs/
* Ensure we're in user context which is safe fot the help to run
* Filter unmountable pseudo filesystem, because they don't have real path
* Supplement the description of this helper function
Changes since v6:
* Fix missing signed-off-by line
Changes since v5:
* Refactor helper avoid unnecessary goto end by having two explicit returns
Changes since v4:
* Rename bpf_fd2path to bpf_get_file_path to be consistent with other
helper's names
* When fdget_raw fails, set ret to -EBADF instead of -EINVAL
* Remove fdput from fdget_raw's error path
* Use IS_ERR instead of IS_ERR_OR_NULL as d_path ether returns a pointer
into the buffer or an error code if the path was too long
* Modify the normal path's return value to return copied string length
including NUL
* Update helper description's Return bits.
* Refactor selftests code for further simplification
Changes since v3:
* Remove unnecessary LOCKDOWN_BPF_READ
* Refactor error handling section for enhanced readability
* Provide a test case in tools/testing/selftests/bpf
* Refactor sefltests code to use real global variables instead of maps
Changes since v2:
* Fix backward compatibility
* Add helper description
* Refactor selftests use global data instead of perf_buffer to simplified
code
* Fix signed-off name
Wenbo Zhang (2):
bpf: add new helper get_file_path for mapping a file descriptor to a
pathname
selftests/bpf: test for bpf_get_file_path() from tracepoint
include/uapi/linux/bpf.h | 29 ++-
kernel/trace/bpf_trace.c | 68 +++++++
tools/include/uapi/linux/bpf.h | 29 ++-
.../selftests/bpf/prog_tests/get_file_path.c | 171 ++++++++++++++++++
.../selftests/bpf/progs/test_get_file_path.c | 43 +++++
5 files changed, 338 insertions(+), 2 deletions(-)
create mode 100644 tools/testing/selftests/bpf/prog_tests/get_file_path.c
create mode 100644 tools/testing/selftests/bpf/progs/test_get_file_path.c
--
2.17.1
Powered by blists - more mailing lists