lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Sat, 04 Jan 2020 20:59:30 +0100
From:   Sven Eckelmann <sven@...fation.org>
To:     "Enrico Weigelt, metux IT consult" <info@...ux.net>
Cc:     linux-kernel@...r.kernel.org, davem@...emloft.net,
        mareklindner@...mailbox.ch, sw@...onwunderlich.de, a@...table.cc,
        marcel@...tmann.org, johan.hedberg@...il.com,
        roopa@...ulusnetworks.com, nikolay@...ulusnetworks.com,
        edumazet@...gle.com, kuznet@....inr.ac.ru, yoshfuji@...ux-ipv6.org,
        jon.maloy@...csson.com, ying.xue@...driver.com, kafai@...com,
        songliubraving@...com, yhs@...com, andriin@...com,
        netdev@...r.kernel.org, linux-bluetooth@...r.kernel.org,
        tipc-discussion@...ts.sourceforge.net,
        linux-hyperv@...r.kernel.org, bpf@...r.kernel.org,
        Matthias Schiffer <mschiffer@...verse-factory.net>,
        b.a.t.m.a.n@...ts.open-mesh.org
Subject: Re: [PATCH 3/8] net: batman-adv: remove unneeded MODULE_VERSION() usage

On Saturday, 4 January 2020 20:51:26 CET Enrico Weigelt, metux IT consult wrote:
> Remove MODULE_VERSION(), as it isn't needed at all: the only version
> making sense is the kernel version.
> 
> Signed-off-by: Enrico Weigelt, metux IT consult <info@...ux.net>
> ---

While it is not strictly required, there are still some consumers that need 
this information to detect the version when installing various modules via 
backports.

Kind regards,
	Sven
Download attachment "signature.asc" of type "application/pgp-signature" (834 bytes)

Powered by blists - more mailing lists