lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Wed, 8 Jan 2020 05:09:12 -0800
From:   Jakub Kicinski <jakub.kicinski@...ronome.com>
To:     Arnd Bergmann <arnd@...db.de>
Cc:     "David S. Miller" <davem@...emloft.net>,
        Simon Horman <simon.horman@...ronome.com>,
        John Hurley <john.hurley@...ronome.com>,
        Jiri Pirko <jiri@...lanox.com>,
        Florian Fainelli <f.fainelli@...il.com>,
        oss-drivers@...ronome.com, Networking <netdev@...r.kernel.org>,
        "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] netronome: fix ipv6 link error

On Tue, 7 Jan 2020 23:01:50 +0100, Arnd Bergmann wrote:
> On Tue, Jan 7, 2020 at 9:44 PM Jakub Kicinski wrote:
> > On Tue,  7 Jan 2020 21:06:40 +0100, Arnd Bergmann wrote:  
> > > When the driver is built-in but ipv6 is a module, the flower
> > > support produces a link error:
> > >
> > > drivers/net/ethernet/netronome/nfp/flower/tunnel_conf.o: In function `nfp_tunnel_keep_alive_v6':
> > > tunnel_conf.c:(.text+0x2aa8): undefined reference to `nd_tbl'  
> >
> > Damn, I guess the v2 of that patch set did not solve _all_ v6 linking
> > issues :/ Thanks for the patch.
> >  
> > > Add a Kconfig dependency to avoid that configuration.
> > >
> > > Fixes: 9ea9bfa12240 ("nfp: flower: support ipv6 tunnel keep-alive messages from fw")
> > > Signed-off-by: Arnd Bergmann <arnd@...db.de>
> > > ---
> > >  drivers/net/ethernet/netronome/Kconfig | 1 +
> > >  1 file changed, 1 insertion(+)
> > >
> > > diff --git a/drivers/net/ethernet/netronome/Kconfig b/drivers/net/ethernet/netronome/Kconfig
> > > index bac5be4d4f43..dcb02ce28460 100644
> > > --- a/drivers/net/ethernet/netronome/Kconfig
> > > +++ b/drivers/net/ethernet/netronome/Kconfig
> > > @@ -31,6 +31,7 @@ config NFP_APP_FLOWER
> > >       bool "NFP4000/NFP6000 TC Flower offload support"
> > >       depends on NFP
> > >       depends on NET_SWITCHDEV
> > > +     depends on IPV6 != m || NFP =m  
> >
> > Could we perhaps do the more standard:
> >
> >         depends on IPV6 || IPV6=n  
> 
> That would have to be on CONFIG_NFP instead of CONFIG_NFP_APP_FLOWER
> then, making the entire driver a module if IPV6=m but always allowing
> CONFIG_NFP_APP_FLOWER.

Ah, indeed.

> > The whitespace around = and != seems a little random as is..  
> 
> Yep, my mistake. I can send a fixed version, please let me know which
> version you want, or fix it up yourself if you find that easier.

Adding the dependency just to NFP_APP_FLOWER seems clean, please just
fix the whitespace and feel free to add my Acked-by to v2.

Powered by blists - more mailing lists