[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200125111709.14566-2-jiri@resnulli.us>
Date: Sat, 25 Jan 2020 12:17:06 +0100
From: Jiri Pirko <jiri@...nulli.us>
To: netdev@...r.kernel.org
Cc: davem@...emloft.net, jakub.kicinski@...ronome.com,
saeedm@...lanox.com, leon@...nel.org, tariqt@...lanox.com,
ayal@...lanox.com, vladbu@...lanox.com, michaelgur@...lanox.com,
moshe@...lanox.com, mlxsw@...lanox.com, dsahern@...il.com
Subject: [patch net-next v2 1/4] net: call call_netdevice_unregister_net_notifiers from unregister
From: Jiri Pirko <jiri@...lanox.com>
The function does the same thing as the existing code, so rather call
call_netdevice_unregister_net_notifiers() instead of code duplication.
Signed-off-by: Jiri Pirko <jiri@...lanox.com>
Reviewed-by: David Ahern <dsahern@...il.com>
---
net/core/dev.c | 14 +++-----------
1 file changed, 3 insertions(+), 11 deletions(-)
diff --git a/net/core/dev.c b/net/core/dev.c
index 4dcc1b390667..3cacfb7184e8 100644
--- a/net/core/dev.c
+++ b/net/core/dev.c
@@ -1764,7 +1764,6 @@ EXPORT_SYMBOL(register_netdevice_notifier);
int unregister_netdevice_notifier(struct notifier_block *nb)
{
- struct net_device *dev;
struct net *net;
int err;
@@ -1775,16 +1774,9 @@ int unregister_netdevice_notifier(struct notifier_block *nb)
if (err)
goto unlock;
- for_each_net(net) {
- for_each_netdev(net, dev) {
- if (dev->flags & IFF_UP) {
- call_netdevice_notifier(nb, NETDEV_GOING_DOWN,
- dev);
- call_netdevice_notifier(nb, NETDEV_DOWN, dev);
- }
- call_netdevice_notifier(nb, NETDEV_UNREGISTER, dev);
- }
- }
+ for_each_net(net)
+ call_netdevice_unregister_net_notifiers(nb, net);
+
unlock:
rtnl_unlock();
up_write(&pernet_ops_rwsem);
--
2.21.0
Powered by blists - more mailing lists