lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 5 Mar 2020 12:28:27 -0600
From:   "Gustavo A. R. Silva" <>
To:     Kalle Valo <>, Joe Perches <>
Cc:     Daniel Drake <>, Ulrich Kunitz <>,
        "David S. Miller" <>,,,
Subject: Re: [PATCH][next] zd1211rw/zd_usb.h: Replace zero-length array with
 flexible-array member


On 3/5/20 10:10, Kalle Valo wrote:
> Joe Perches <> writes:
>> On Thu, 2020-03-05 at 16:50 +0200, Kalle Valo wrote:
>>> "Gustavo A. R. Silva" <> writes:
>> []
>>>>  drivers/net/wireless/zydas/zd1211rw/zd_usb.h | 8 ++++----
>>>>  1 file changed, 4 insertions(+), 4 deletions(-)
>>> "zd1211rw: " is enough, no need to have the filename in the title.
>>> But I asked this already in an earlier patch, who prefers this format?
>>> It already got opposition so I'm not sure what to do.
>> I think it doesn't matter.
>> Trivial inconsistencies in patch subject and word choice
>> don't have much overall impact.
> I wrote in a confusing way, my question above was about the actual patch
> and not the the title. For example, Jes didn't like this style change:

It doesn't seem that that comment adds a lot to the conversation. The only
thing that it says is literally "fix the compiler". By the way, more than
a hundred patches have already been applied to linux-next[1] and he seems
to be the only person that has commented such a thing. Qemu guys are adopting
this format, too[2][3].

On the other hand, the changelog text explains the reasons why we are
implementing this change all across the kernel tree. :)



Powered by blists - more mailing lists