lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 07 Apr 2020 13:19:11 -0700 (PDT)
From:   David Miller <davem@...emloft.net>
To:     leon@...nel.org
Cc:     ka-cheong.poon@...cle.com, netdev@...r.kernel.org,
        santosh.shilimkar@...cle.com, rds-devel@....oracle.com,
        sironhide0null@...il.com
Subject: Re: [PATCH net 1/2] net/rds: Replace direct refcount_inc() by
 inline function

From: Leon Romanovsky <leon@...nel.org>
Date: Tue, 7 Apr 2020 21:48:09 +0300

> On Tue, Apr 07, 2020 at 09:08:01AM -0700, Ka-Cheong Poon wrote:
>> Added rds_ib_dev_get() and rds_mr_get() to improve code readability.
> 
> It is very hard to agree with this sentence.
> Hiding basic kernel primitives is very rare will improve code readability.
> It is definitely not the case here.

I completely agree.

Powered by blists - more mailing lists