[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20200525145130.przpqlspg6nnylke@linutronix.de>
Date: Mon, 25 May 2020 16:51:30 +0200
From: Sebastian Andrzej Siewior <bigeasy@...utronix.de>
To: Ingo Molnar <mingo@...nel.org>
Cc: linux-kernel@...r.kernel.org,
Peter Zijlstra <peterz@...radead.org>,
Steven Rostedt <rostedt@...dmis.org>,
Will Deacon <will@...nel.org>,
Thomas Gleixner <tglx@...utronix.de>,
"Paul E . McKenney" <paulmck@...nel.org>,
Linus Torvalds <torvalds@...ux-foundation.org>,
Matthew Wilcox <willy@...radead.org>,
Mike Galbraith <umgwanakikbuti@...il.com>,
Evgeniy Polyakov <zbr@...emap.net>, netdev@...r.kernel.org
Subject: Re: [PATCH v2 5/7] connector/cn_proc: Protect send_msg() with a
local lock
On 2020-05-25 09:18:19 [+0200], Ingo Molnar wrote:
> > +static DEFINE_PER_CPU(struct local_evt, local_evt) = {
> > + .counts = 0,
>
> I don't think zero initializations need to be written out explicitly.
yes.
> > + .lock = INIT_LOCAL_LOCK(lock),
> > +};
> >
> > static inline void send_msg(struct cn_msg *msg)
> > {
> > - preempt_disable();
> > + local_lock(&local_evt.lock);
> >
> > - msg->seq = __this_cpu_inc_return(proc_event_counts) - 1;
> > + msg->seq = __this_cpu_inc_return(local_evt.counts) - 1;
>
> Naming nit: renaming this from 'proc_event_counts' to
> 'local_evt.counts' is a step back IMO - what's an 'evt',
> did we run out of e's? ;-)
>
> Should be something like local_event.count? (Singular.)
okay.
> Thanks,
>
> Ingo
Sebastian
Powered by blists - more mailing lists