[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <HE1PR0802MB25552E7C792D3BB9CBE2D2C7F4B30@HE1PR0802MB2555.eurprd08.prod.outlook.com>
Date: Mon, 25 May 2020 04:50:28 +0000
From: Jianyong Wu <Jianyong.Wu@....com>
To: Richard Cochran <richardcochran@...il.com>,
"maz@...nel.org" <maz@...nel.org>
CC: "netdev@...r.kernel.org" <netdev@...r.kernel.org>,
"yangbo.lu@....com" <yangbo.lu@....com>,
"john.stultz@...aro.org" <john.stultz@...aro.org>,
"tglx@...utronix.de" <tglx@...utronix.de>,
"pbonzini@...hat.com" <pbonzini@...hat.com>,
"sean.j.christopherson@...el.com" <sean.j.christopherson@...el.com>,
Mark Rutland <Mark.Rutland@....com>,
"will@...nel.org" <will@...nel.org>,
Suzuki Poulose <Suzuki.Poulose@....com>,
Steven Price <Steven.Price@....com>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"linux-arm-kernel@...ts.infradead.org"
<linux-arm-kernel@...ts.infradead.org>,
"kvmarm@...ts.cs.columbia.edu" <kvmarm@...ts.cs.columbia.edu>,
"kvm@...r.kernel.org" <kvm@...r.kernel.org>,
Steve Capper <Steve.Capper@....com>,
Kaly Xin <Kaly.Xin@....com>, Justin He <Justin.He@....com>,
Wei Chen <Wei.Chen@....com>, nd <nd@....com>
Subject: RE: [RFC PATCH v12 10/11] arm64: add mechanism to let user choose
which counter to return
Hi Richard,
> -----Original Message-----
> From: Richard Cochran <richardcochran@...il.com>
> Sent: Sunday, May 24, 2020 10:11 AM
> To: Jianyong Wu <Jianyong.Wu@....com>
> Cc: netdev@...r.kernel.org; yangbo.lu@....com; john.stultz@...aro.org;
> tglx@...utronix.de; pbonzini@...hat.com; sean.j.christopherson@...el.com;
> maz@...nel.org; Mark Rutland <Mark.Rutland@....com>; will@...nel.org;
> Suzuki Poulose <Suzuki.Poulose@....com>; Steven Price
> <Steven.Price@....com>; linux-kernel@...r.kernel.org; linux-arm-
> kernel@...ts.infradead.org; kvmarm@...ts.cs.columbia.edu;
> kvm@...r.kernel.org; Steve Capper <Steve.Capper@....com>; Kaly Xin
> <Kaly.Xin@....com>; Justin He <Justin.He@....com>; Wei Chen
> <Wei.Chen@....com>; nd <nd@....com>
> Subject: Re: [RFC PATCH v12 10/11] arm64: add mechanism to let user choose
> which counter to return
>
> On Fri, May 22, 2020 at 04:37:23PM +0800, Jianyong Wu wrote:
> > In general, vm inside will use virtual counter compered with host use
> > phyical counter. But in some special scenarios, like nested
> > virtualization, phyical counter maybe used by vm. A interface added in
> > ptp_kvm driver to offer a mechanism to let user choose which counter
> > should be return from host.
>
> Sounds like you have two time sources, one for normal guest, and one for
> nested. Why not simply offer the correct one to user space automatically? If
> that cannot be done, then just offer two PHC devices with descriptive names.
>
It's a good idea, but in most case physical counter will not be used, so it's better not keep 2 ptp devices all the time.
How about adding an extra argument in struct ptp_clock_info to serve as a flag, then we can control this flag using IOCTL to determine the counter type.
In this way, no extra arguments needed in .getcrosststamp. But we also need specific code in ptp_ioctl to implement it like in this patch.
The second way, maybe we can use the flag as a module parameter, this is easier to implement.
@maz@...nel.org WDYT?
> > diff --git a/drivers/ptp/ptp_chardev.c b/drivers/ptp/ptp_chardev.c
> > index fef72f29f3c8..8b0a7b328bcd 100644
> > --- a/drivers/ptp/ptp_chardev.c
> > +++ b/drivers/ptp/ptp_chardev.c
> > @@ -123,6 +123,9 @@ long ptp_ioctl(struct posix_clock *pc, unsigned int
> cmd, unsigned long arg)
> > struct timespec64 ts;
> > int enable, err = 0;
> >
> > +#ifdef CONFIG_ARM64
> > + static long flag;
>
> static? This is not going to fly.
Need remove here.
>
> > + * In most cases, we just need virtual counter from host and
> > + * there is limited scenario using this to get physical counter
> > + * in guest.
> > + * Be careful to use this as there is no way to set it back
> > + * unless you reinstall the module.
>
> How on earth is the user supposed to know this?
>
Yeah, It's odd , should be removed.
> From your description, this "flag" really should be a module parameter.
Maybe use flag as a module parameter is a better way.
Thanks
Jianyong
>
> Thanks,
> Richard
Powered by blists - more mailing lists