lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 29 May 2020 09:56:00 +0800
From:   tanhuazhong <tanhuazhong@...wei.com>
To:     Markus Elfring <Markus.Elfring@....de>, <netdev@...r.kernel.org>
CC:     <linux-kernel@...r.kernel.org>, <linuxarm@...wei.com>,
        "David S. Miller" <davem@...emloft.net>,
        Jakub Kicinski <kuba@...nel.org>,
        Salil Mehta <salil.mehta@...wei.com>,
        Yisen Zhuang <yisen.zhuang@...wei.com>
Subject: Re: [PATCH 02/12] net: hns3: Destroy a mutex after initialisation
 failure in hclge_init_ad_dev()



On 2020/5/29 2:42, Markus Elfring wrote:
>> Add a mutex destroy call in hclge_init_ae_dev() when fails.
> 
> How do you think about a wording variant like the following?
> 
>     Change description:
>     The function “mutex_init” was called before a call of
>     the function “hclge_pci_init”.
>     But the function “mutex_destroy” was not called after initialisation
>     steps failed.
>     Thus add the missed function call for the completion of
>     the exception handling.
> 

It looks better. I will try to improve the skill of patch description
and make as many as people can understand the patch.

Thanks for help.

> 
> Would you like to add the tag “Fixes” to the commit message?
> 

Since it seems not a very urgent issue, so i send it to the -next
and make it as a code optimization.

Thanks:)

> 
> …
>> +++ b/drivers/net/ethernet/hisilicon/hns3/hns3pf/hclge_main.c
>> @@ -10108,6 +10108,7 @@ static int hclge_init_ae_dev(struct hnae3_ae_dev *ae_dev)
>>   	pci_release_regions(pdev);
>>   	pci_disable_device(pdev);
>>   out:
>> +	mutex_destroy(&hdev->vport_lock);
>>   	return ret;
>>   }
> 
> How do you think about to use the label “destroy_mutex” instead?

Will use label 'destroy_mutex‘ instead if there is another patch need to 
modify this code, which is more readable.

Thanks for your comments.

> 
> Regards,
> Markus
> 
> 

Powered by blists - more mailing lists