[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200620154347.3587114-1-olteanv@gmail.com>
Date: Sat, 20 Jun 2020 18:43:35 +0300
From: Vladimir Oltean <olteanv@...il.com>
To: davem@...emloft.net, netdev@...r.kernel.org
Cc: UNGLinuxDriver@...rochip.com, andrew@...n.ch, f.fainelli@...il.com,
vivien.didelot@...il.com, claudiu.manoil@....com,
alexandru.marginean@....com, xiaoliang.yang_1@....com
Subject: [PATCH net-next 00/12] Ocelot/Felix driver cleanup
From: Vladimir Oltean <vladimir.oltean@....com>
Some of the code in the mscc felix and ocelot drivers was added while in
a bit of a hurry. Let's take a moment and put things in relative order.
First 3 patches are sparse warning fixes.
Patches 4-9 perform some further splitting between mscc_felix,
mscc_ocelot, and the common hardware library they share. Meaning that
some code is being moved from the library into just the mscc_ocelot
module.
Patches 10-12 refactor the naming conventions in the existing VCAP code
(for tc-flower offload), since we're going to be adding some more code
for VCAP IS1 (previous tentatives already submitted here:
https://patchwork.ozlabs.org/project/netdev/cover/20200602051828.5734-1-xiaoliang.yang_1@nxp.com/),
and that code would be confusing to read and maintain using current
naming conventions.
No functional modification is intended. I checked that the VCAP IS2 code
still works by applying a tc ingress filter with an EtherType key and
'drop' action.
Vladimir Oltean (12):
net: dsa: felix: make vcap is2 keys and actions static
net: mscc: ocelot: use plain int when interacting with TCAM tables
net: mscc: ocelot: access EtherType using __be16
net: mscc: ocelot: rename ocelot_board.c to ocelot_vsc7514.c
net: mscc: ocelot: rename module to mscc_ocelot
net: mscc: ocelot: convert MSCC_OCELOT_SWITCH into a library
net: mscc: ocelot: rename MSCC_OCELOT_SWITCH_OCELOT to
MSCC_OCELOT_SWITCH
net: mscc: ocelot: move ocelot_regs.c into ocelot_vsc7514.c
net: mscc: ocelot: move net_device related functions to ocelot_net.c
net: mscc: ocelot: rename ocelot_ace.{c,h} to ocelot_vcap.{c,h}
net: mscc: ocelot: generalize the "ACE/ACL" names
net: mscc: ocelot: unexpose ocelot_vcap_policer_{add,del}
drivers/net/dsa/ocelot/Kconfig | 4 +-
drivers/net/dsa/ocelot/felix_vsc9959.c | 4 +-
drivers/net/ethernet/mscc/Kconfig | 22 +-
drivers/net/ethernet/mscc/Makefile | 16 +-
drivers/net/ethernet/mscc/ocelot.c | 913 +-------------
drivers/net/ethernet/mscc/ocelot.h | 46 +-
drivers/net/ethernet/mscc/ocelot_board.c | 626 ----------
drivers/net/ethernet/mscc/ocelot_flower.c | 146 +--
drivers/net/ethernet/mscc/ocelot_net.c | 1031 ++++++++++++++++
drivers/net/ethernet/mscc/ocelot_police.c | 49 +-
drivers/net/ethernet/mscc/ocelot_police.h | 25 +-
drivers/net/ethernet/mscc/ocelot_regs.c | 450 -------
drivers/net/ethernet/mscc/ocelot_tc.c | 179 ---
drivers/net/ethernet/mscc/ocelot_tc.h | 22 -
.../mscc/{ocelot_ace.c => ocelot_vcap.c} | 336 +++---
.../mscc/{ocelot_ace.h => ocelot_vcap.h} | 88 +-
drivers/net/ethernet/mscc/ocelot_vsc7514.c | 1068 +++++++++++++++++
include/soc/mscc/ocelot.h | 4 +-
18 files changed, 2510 insertions(+), 2519 deletions(-)
delete mode 100644 drivers/net/ethernet/mscc/ocelot_board.c
create mode 100644 drivers/net/ethernet/mscc/ocelot_net.c
delete mode 100644 drivers/net/ethernet/mscc/ocelot_regs.c
delete mode 100644 drivers/net/ethernet/mscc/ocelot_tc.c
delete mode 100644 drivers/net/ethernet/mscc/ocelot_tc.h
rename drivers/net/ethernet/mscc/{ocelot_ace.c => ocelot_vcap.c} (77%)
rename drivers/net/ethernet/mscc/{ocelot_ace.h => ocelot_vcap.h} (75%)
create mode 100644 drivers/net/ethernet/mscc/ocelot_vsc7514.c
--
2.25.1
Powered by blists - more mailing lists