lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Sat, 25 Jul 2020 18:26:47 +0300
From:   علي محمد جبار 
        <alimjalnasrawy@...il.com>
To:     Michal Kubecek <mkubecek@...e.cz>
Cc:     netdev@...r.kernel.org, Florian Fainelli <f.fainelli@...il.com>
Subject: Re: ethtool 5.7: --change commands fail

On Sat, Jul 25, 2020 at 3:54 PM Michal Kubecek <mkubecek@...e.cz> wrote:
>
> On Sat, Jul 25, 2020 at 09:49:36AM +0300, Ali MJ Al-Nasrawy wrote:
> > ethtool: v5.7
> > kernel: v5.4.52
> > driver: r8169 + libphy
> >
> > Starting from v5.7, all ethtool --change commands fail to apply and
> > show the following error message:
> >
> > $ ethtool -s ens5 autoneg off
> > netlink error: No such file or directory
> > Cannot set new settings: No such file or directory
> >   not setting autoneg
> >
> > 'git bisect' points to:
> > 8bb9a04 (ethtool.c: Report transceiver correctly)
> >
> > After debugging I found that this commit sets deprecated.transceiver
> > and then do_ioctl_slinksettings() checks for it and returns -1.
> > errno is thus invalid and the the error message is bogus.
> >
> > With debugging enabled:
> >
> > $ ethtool --debug 0xffff -s ens5 autoneg off
> > sending genetlink packet (32 bytes):
> >     msg length 32 genl-ctrl
> >     CTRL_CMD_GETFAMILY
> >         CTRL_ATTR_FAMILY_NAME = "ethtool"
> > <message dump/>
> > received genetlink packet (52 bytes):
> >     msg length 52 error errno=-2
> > <message dump/>
> > netlink error: No such file or directory
> > offending message:
> >     ETHTOOL_MSG_LINKINFO_SET
> >         ETHTOOL_A_LINKINFO_PORT = 101
> > Cannot set new settings: No such file or directory
> >   not setting autoneg
>
> Kernel 5.4.x does not support ethtool netlink so that we fall back to
> ioctl. While we want to report transceiver in "ethtool <dev>" output, we
> must not pass the value retrieved from kernel back to kernel when
> "ethtool -s <dev> ..." command is executed.
>
> Does the patch below help in your setup?

Yes, it fixed the issue. Thank you.

Ali

>
> Michal
>
>
> diff --git a/ethtool.c b/ethtool.c
> index d37c223dcc04..1b99ac91dcbf 100644
> --- a/ethtool.c
> +++ b/ethtool.c
> @@ -2906,6 +2906,8 @@ static int do_sset(struct cmd_context *ctx)
>                 struct ethtool_link_usettings *link_usettings;
>
>                 link_usettings = do_ioctl_glinksettings(ctx);
> +               memset(&link_usettings->deprecated, 0,
> +                      sizeof(link_usettings->deprecated));
>                 if (link_usettings == NULL)
>                         link_usettings = do_ioctl_gset(ctx);
>                 if (link_usettings == NULL) {

Powered by blists - more mailing lists