lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 20 Aug 2020 19:22:15 -0700
From:   Hao Luo <>
To:     Alexei Starovoitov <>
Cc:     Networking <>, bpf <>,
        open list <>,
        "open list:KERNEL SELFTEST FRAMEWORK" 
        <>, Shuah Khan <>,
        Alexei Starovoitov <>,
        Andrii Nakryiko <>,
        Daniel Borkmann <>,
        Martin KaFai Lau <>,
        Song Liu <>, Yonghong Song <>,
        John Fastabend <>,
        KP Singh <>,
        Quentin Monnet <>,
        Steven Rostedt <>,
        Ingo Molnar <>, Andrey Ignatov <>,
        Jakub Sitnicki <>
Subject: Re: [PATCH bpf-next v1 1/8] bpf: Introduce pseudo_btf_id

On Thu, Aug 20, 2020 at 2:53 PM Alexei Starovoitov
<> wrote:
> Why did you choose to do it during main do_check() walk instead of this pre-pass ?
> check_ld_imm() can be called multiple times for the same insn,
> so it's faster and less surprising to do it during replace_map_fd_with_map_ptr().
> BTF needs to be parsed first, of course.
> You can either move check_btf_info() before replace_map_fd_with_map_ptr() or
> move replace_map_fd_with_map_ptr() after check_btf_info().
> The latter is probably cleaner.

Ah, that does make more sense. I can move
replace_map_fd_with_map_ptr() after check_btf_info() (or
check_attach_btf_id()) and rename it to better reflect the fact that
it's not just for maps now.

Thanks for the insights!

Powered by blists - more mailing lists