lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 8 Sep 2020 20:33:02 +0800
From:   Chris Chiu <chiu@...lessm.com>
To:     sean.wang@...iatek.com, ryder.lee@...iatek.com,
        Kalle Valo <kvalo@...eaurora.org>,
        David Miller <davem@...emloft.net>, kuba@...nel.org,
        nbd@....name, lorenzo@...nel.org,
        linux-wireless <linux-wireless@...r.kernel.org>,
        netdev <netdev@...r.kernel.org>,
        Linux Kernel <linux-kernel@...r.kernel.org>
Subject: mt7615: Fail to load firmware on AZWAVE-CB434NF module

Hi Sean, Ryder,
    We have an ASUS laptop X532EQ with the wifi module AZWAVE-CB434NF
which fails to bring up the wifi interface on kernel 5.9.0-rc1. The
dmesg shows the firmware load error.

[   25.630850] mt7615e 0000:2d:00.0: Message -4294967280 (seq 1) timeout
[   25.630851] mt7615e 0000:2d:00.0: Failed to get patch semaphore
[   25.630853] mt7615e 0000:2d:00.0: mediatek/mt7663pr2h.bin not
found, switching to mediatek/mt7663pr2h_rebb.bin
[   46.111154] mt7615e 0000:2d:00.0: Message -4294967280 (seq 2) timeout
[   46.111178] mt7615e 0000:2d:00.0: Failed to get patch semaphore
[   46.111179] mt7615e 0000:2d:00.0: failed to load mediatek/mt7663pr2h_rebb.bin

The lspci information for the device shows as follows
0000:2d:00.0 Network controller [0280]: MEDIATEK Corp. Device [14c3:7663]
        Subsystem: AzureWave Device [1a3b:4341]
        Flags: bus master, fast devsel, latency 0, IRQ 177
        Memory at 6032100000 (64-bit, prefetchable) [size=1M]
        Memory at 6032200000 (64-bit, prefetchable) [size=16K]
        Memory at 6032204000 (64-bit, prefetchable) [size=4K]
        Capabilities: [80] Express Endpoint, MSI 1f
        Capabilities: [e0] MSI: Enable+ Count=1/32 Maskable+ 64bit+
        Capabilities: [f8] Power Management version 3
        Capabilities: [100] Vendor Specific Information: ID=1556 Rev=1
Len=008 <?>
        Capabilities: [108] Latency Tolerance Reporting
        Capabilities: [110] L1 PM Substates
        Capabilities: [200] Advanced Error Reporting
        Kernel driver in use: mt7615e
        Kernel modules: mt7615e

I also tried the latest linux-firmware with the most up to date
mediatek firmware
https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/commit/?id=7a237c6ee2c7af48723c356461ef80270a52d2c6.
But still get the same error.

Any suggestions on what I can do here?

Chris

Powered by blists - more mailing lists