lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 9 Sep 2020 18:06:33 -0700
From:   Jakub Kicinski <kuba@...nel.org>
To:     Jacob Keller <jacob.e.keller@...el.com>
Cc:     netdev@...r.kernel.org
Subject: Re: [net-next v4 5/5] ice: add support for flash update overwrite
 mask

On Wed,  9 Sep 2020 15:26:53 -0700 Jacob Keller wrote:
> Support the recently added DEVLINK_ATTR_FLASH_UPDATE_OVERWRITE_MASK
> parameter in the ice flash update handler. Convert the overwrite mask
> bitfield into the appropriate preservation level used by the firmware
> when updating.
> 
> Because there is no equivalent preservation level for overwriting only
> identifiers, this combination is rejected by the driver as not supported
> with an appropriate extended ACK message.
> 
> Signed-off-by: Jacob Keller <jacob.e.keller@...el.com>

Reviewed-by: Jakub Kicinski <kuba@...nel.org>

Powered by blists - more mailing lists