lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Sat, 26 Sep 2020 20:45:13 +0300
From:   Vladimir Oltean <>
To:     Andrew Lunn <>
Cc:     Vladimir Oltean <>,
        netdev <>,
        Florian Fainelli <>,
        Jakub Kicinski <>, Jiri Pirko <>,
        Chris Healy <>
Subject: Re: [PATCH net-next RFC v1 3/4] net: dsa: Add helper for converting
 devlink port to ds and port

On Sat, Sep 26, 2020 at 07:28:26PM +0200, Andrew Lunn wrote:
> Hi Vladimir
> Just finishing off the next version of these patches, and i looped
> back to check i addressed all the comments.
> This one i tend to disagree with. If you look at DSA drivers, a port
> variable is always an integer index. dp is used to refer to a
> dsa_port.
> If anything, i would suggest we rename dsa_to_port() to dsa_to_dp(),
> and dsa_port_from_netdev to dsa_dp_from_netdev() or maybe
> dsa_netdev_to_dp().

Maybe it's just me, but I don't like the "dp" name too much, and I think
all conversions of those functions sound worse with the new names.
But you do have a point with the inconsistency, so I suppose you could
leave the name as it is? Or maybe dsa_dlp_to_port() if you fancy that
abbreviation for a devlink port?

Powered by blists - more mailing lists