[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200926173108.1230014-15-vladimir.oltean@nxp.com>
Date: Sat, 26 Sep 2020 20:31:06 +0300
From: Vladimir Oltean <vladimir.oltean@....com>
To: netdev@...r.kernel.org, davem@...emloft.net
Cc: andrew@...n.ch, f.fainelli@...il.com, vivien.didelot@...il.com,
kuba@...nel.org
Subject: [PATCH v2 net-next 14/16] net: dsa: tag_qca: use the generic flow dissector procedure
Refactor the .flow_dissect procedure to call the common helper instead
of open-coding the header displacement.
Cc: John Crispin <john@...ozen.org>
Cc: Alexander Lobakin <alobakin@...me>
Signed-off-by: Vladimir Oltean <vladimir.oltean@....com>
---
net/dsa/tag_qca.c | 9 +--------
1 file changed, 1 insertion(+), 8 deletions(-)
diff --git a/net/dsa/tag_qca.c b/net/dsa/tag_qca.c
index a75c6b20c215..bb929b8092cb 100644
--- a/net/dsa/tag_qca.c
+++ b/net/dsa/tag_qca.c
@@ -89,19 +89,12 @@ static struct sk_buff *qca_tag_rcv(struct sk_buff *skb, struct net_device *dev,
return skb;
}
-static void qca_tag_flow_dissect(const struct sk_buff *skb, __be16 *proto,
- int *offset)
-{
- *offset = QCA_HDR_LEN;
- *proto = ((__be16 *)skb->data)[0];
-}
-
static const struct dsa_device_ops qca_netdev_ops = {
.name = "qca",
.proto = DSA_TAG_PROTO_QCA,
.xmit = qca_tag_xmit,
.rcv = qca_tag_rcv,
- .flow_dissect = qca_tag_flow_dissect,
+ .flow_dissect = dsa_tag_generic_flow_dissect,
.overhead = QCA_HDR_LEN,
};
--
2.25.1
Powered by blists - more mailing lists