[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20200929031754-mutt-send-email-mst@kernel.org>
Date: Tue, 29 Sep 2020 03:21:54 -0400
From: "Michael S. Tsirkin" <mst@...hat.com>
To: Tonghao Zhang <xiangxia.m.yue@...il.com>
Cc: Jason Wang <jasowang@...hat.com>,
Willem de Bruijn <willemb@...gle.com>,
virtualization@...ts.linux-foundation.org,
Linux Kernel Network Developers <netdev@...r.kernel.org>
Subject: Re: [PATCH net v2] virtio-net: don't disable guest csum when disable
LRO
On Tue, Sep 29, 2020 at 02:59:03PM +0800, Tonghao Zhang wrote:
> On Tue, Sep 29, 2020 at 2:23 PM Michael S. Tsirkin <mst@...hat.com> wrote:
> >
> > On Tue, Sep 29, 2020 at 09:58:06AM +0800, xiangxia.m.yue@...il.com wrote:
> > > From: Tonghao Zhang <xiangxia.m.yue@...il.com>
> > >
> > > Open vSwitch and Linux bridge will disable LRO of the interface
> > > when this interface added to them. Now when disable the LRO, the
> > > virtio-net csum is disable too. That drops the forwarding performance.
> > >
> > > Fixes: a02e8964eaf9 ("virtio-net: ethtool configurable LRO")
> > > Cc: Michael S. Tsirkin <mst@...hat.com>
> > > Cc: Jason Wang <jasowang@...hat.com>
> > > Cc: Willem de Bruijn <willemb@...gle.com>
> > > Signed-off-by: Tonghao Zhang <xiangxia.m.yue@...il.com>
> > > ---
> > > v2:
> > > * change the fix-tag
> > > ---
> > > drivers/net/virtio_net.c | 8 +++++++-
> > > 1 file changed, 7 insertions(+), 1 deletion(-)
> > >
> > > diff --git a/drivers/net/virtio_net.c b/drivers/net/virtio_net.c
> > > index 7145c83c6c8c..21b71148c532 100644
> > > --- a/drivers/net/virtio_net.c
> > > +++ b/drivers/net/virtio_net.c
> > > @@ -63,6 +63,11 @@ static const unsigned long guest_offloads[] = {
> > > VIRTIO_NET_F_GUEST_CSUM
> > > };
> > >
> > > +#define GUEST_OFFLOAD_LRO_MASK ((1ULL << VIRTIO_NET_F_GUEST_TSO4) | \
> > > + (1ULL << VIRTIO_NET_F_GUEST_TSO6) | \
> > > + (1ULL << VIRTIO_NET_F_GUEST_ECN) | \
> > > + (1ULL << VIRTIO_NET_F_GUEST_UFO))
> > > +
> >
> > I think I'd rather we open-coded this, the macro is only
> > used in one place ...
> Yes, in this patch, it is used only in one place. But in next patch
> [1], we use it twice and that make the code look a bit nicer.
> Would we open-coded this in this patch ?
>
> [1] - http://patchwork.ozlabs.org/project/netdev/patch/20200928033915.82810-2-xiangxia.m.yue@gmail.com/
OK then maybe keep this in a series like you did with v1.
> > > struct virtnet_stat_desc {
> > > char desc[ETH_GSTRING_LEN];
> > > size_t offset;
> > > @@ -2531,7 +2536,8 @@ static int virtnet_set_features(struct net_device *dev,
> > > if (features & NETIF_F_LRO)
> > > offloads = vi->guest_offloads_capable;
> > > else
> > > - offloads = 0;
> > > + offloads = vi->guest_offloads_capable &
> > > + ~GUEST_OFFLOAD_LRO_MASK;
> > >
> > > err = virtnet_set_guest_offloads(vi, offloads);
> > > if (err)
> >
> > > --
> > > 2.23.0
> >
>
>
> --
> Best regards, Tonghao
Powered by blists - more mailing lists