[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAEf4BzZTBxCKp2JT0yuwBwWX-EuqdSAOM7Duz7ifkRzeYKbKJw@mail.gmail.com>
Date: Fri, 2 Oct 2020 11:11:54 -0700
From: Andrii Nakryiko <andrii.nakryiko@...il.com>
To: Hangbin Liu <liuhangbin@...il.com>
Cc: bpf <bpf@...r.kernel.org>, Alexei Starovoitov <ast@...nel.org>,
Daniel Borkmann <daniel@...earbox.net>,
Song Liu <songliubraving@...com>, Yonghong Song <yhs@...com>,
Andrii Nakryiko <andriin@...com>,
Networking <netdev@...r.kernel.org>,
Toke Høiland-Jørgensen <toke@...hat.com>
Subject: Re: [PATCH libbpf] libbpf: check if pin_path was set even map fd exist
On Fri, Oct 2, 2020 at 12:58 AM Hangbin Liu <liuhangbin@...il.com> wrote:
>
> Say a user reuse map fd after creating a map manually and set the
> pin_path, then load the object via libbpf.
>
> In libbpf bpf_object__create_maps(), bpf_object__reuse_map() will
> return 0 if there is no pinned map in map->pin_path. Then after
> checking if map fd exist, we should also check if pin_path was set
> and do bpf_map__pin() instead of continue the loop.
>
> Fix it by creating map if fd not exist and continue checking pin_path
> after that.
>
> Suggested-by: Andrii Nakryiko <andrii.nakryiko@...il.com>
> Signed-off-by: Hangbin Liu <liuhangbin@...il.com>
> ---
> tools/lib/bpf/libbpf.c | 75 +++++++++++++++++++++---------------------
> 1 file changed, 37 insertions(+), 38 deletions(-)
>
Please add a selftests that validates the logic you are going to rely on.
> + targ_map = map->init_slots[j];
> + fd = bpf_map__fd(targ_map);
> + err = bpf_map_update_elem(map->fd, &j, &fd, 0);
> + if (err) {
> + err = -errno;
> + pr_warn("map '%s': failed to initialize slot [%d] to map '%s' fd=%d: %d\n",
> + map->name, j, targ_map->name,
> + fd, err);
I just noticed that we don't zclose(map->fd) here, can you please fix
it with a separate patch along these changes? Thanks!
> + goto err_out;
> + }
> + pr_debug("map '%s': slot [%d] set to map '%s' fd=%d\n",
> + map->name, j, targ_map->name, fd);
> + }
> + zfree(&map->init_slots);
> + map->init_slots_sz = 0;
Let's move this slot initting logic into a helper function
(init_map_slots() or something like that? doesn't have to use
"bpf_object__" prefix as it is internal static function), that will
simplify overall flow.
> + }
> + } else {
> + pr_debug("map '%s': skipping creation (preset fd=%d)\n",
> + map->name, map->fd);
to make diff a bit smaller, maybe let's keep the original order, but
do if/else instead of continuing:
if (map->fd >= 0) {
pr_debug("skipping...");
} else {
/* do the creation here */
}
/* pinning logic here */
> }
>
> if (map->pin_path && !map->pinned) {
> --
> 2.25.4
>
Powered by blists - more mailing lists