[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20201011151332.3123c94e@kicinski-fedora-pc1c0hjn.dhcp.thefacebook.com>
Date: Sun, 11 Oct 2020 15:13:32 -0700
From: Jakub Kicinski <kuba@...nel.org>
To: Heiner Kallweit <hkallweit1@...il.com>
Cc: David Miller <davem@...emloft.net>,
"netdev@...r.kernel.org" <netdev@...r.kernel.org>
Subject: Re: [PATCH RFC] net: add helper eth_set_protocol
On Tue, 6 Oct 2020 22:10:00 +0200 Heiner Kallweit wrote:
> In all cases I've seen eth_type_trans() is used as in the new helper.
> Biggest benefit is improved readability when replacing statements like
> the following:
> desc->skb->protocol = eth_type_trans(desc->skb, priv->dev);
>
> Coccinelle tells me that using the new helper tree-wide would touch
> 313 files. Therefore I'd like to check for feedback before bothering
> 100+ maintainers.
>
> Signed-off-by: Heiner Kallweit <hkallweit1@...il.com>
FWIW in case you're planning to start sending conversion patches..
I'm not 100% sold on this. Maybe it's because I'm used to the call
as it is. I don't feel like eth_set_protocol() expresses what
eth_type_trans() does well enough. Besides there's a whole bunch of
*_type_trans calls for different (old) L2s, are we going to leave those
as they are?
> diff --git a/include/linux/etherdevice.h b/include/linux/etherdevice.h
> index 2e5debc03..c7f89b1bf 100644
> --- a/include/linux/etherdevice.h
> +++ b/include/linux/etherdevice.h
> @@ -64,6 +64,11 @@ static const u8 eth_reserved_addr_base[ETH_ALEN] __aligned(2) =
> { 0x01, 0x80, 0xc2, 0x00, 0x00, 0x00 };
> #define eth_stp_addr eth_reserved_addr_base
>
> +static inline void eth_set_protocol(struct sk_buff *skb, struct net_device *dev)
> +{
> + skb->protocol = eth_type_trans(skb, dev);
> +}
> +
> /**
> * is_link_local_ether_addr - Determine if given Ethernet address is link-local
> * @addr: Pointer to a six-byte array containing the Ethernet address
Powered by blists - more mailing lists