lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 15 Oct 2020 12:32:29 +0800
From:   Coiby Xu <>
To:     Benjamin Poirier <>
Cc:, Shung-Hsi Yu <>,
        Willem de Bruijn <>,
        Dan Carpenter <>,
        Manish Chopra <>,
        "supporter:QLOGIC QLGE 10Gb ETHERNET DRIVER" 
        Greg Kroah-Hartman <>,
        "open list:QLOGIC QLGE 10Gb ETHERNET DRIVER" <>,
        open list <>
Subject: Re: [PATCH v2 1/7] staging: qlge: replace ql_* with qlge_* to avoid
 namespace clashes with other qlogic drivers

On Thu, Oct 15, 2020 at 12:26:28PM +0800, Coiby Xu wrote:
>On Thu, Oct 15, 2020 at 10:01:36AM +0900, Benjamin Poirier wrote:
>>On 2020-10-14 18:43 +0800, Coiby Xu wrote:
>>>To avoid namespace clashes with other qlogic drivers and also for the
>>>sake of naming consistency, use the "qlge_" prefix as suggested in
>>>Suggested-by: Benjamin Poirier <>
>>>Signed-off-by: Coiby Xu <>
>>> drivers/staging/qlge/TODO           |    4 -
>>> drivers/staging/qlge/qlge.h         |  190 ++--
>>> drivers/staging/qlge/qlge_dbg.c     | 1073 ++++++++++++-----------
>>> drivers/staging/qlge/qlge_ethtool.c |  231 ++---
>>> drivers/staging/qlge/qlge_main.c    | 1257 +++++++++++++--------------
>>> drivers/staging/qlge/qlge_mpi.c     |  352 ++++----
>>> 6 files changed, 1551 insertions(+), 1556 deletions(-)
>>>diff --git a/drivers/staging/qlge/TODO b/drivers/staging/qlge/TODO
>>>index f93f7428f5d5..5ac55664c3e2 100644
>>>--- a/drivers/staging/qlge/TODO
>>>+++ b/drivers/staging/qlge/TODO
>>>@@ -28,10 +28,6 @@
>>> * the driver has a habit of using runtime checks where compile time checks are
>>>   possible (ex. ql_free_rx_buffers(), ql_alloc_rx_buffers())
>>> * reorder struct members to avoid holes if it doesn't impact performance
>>>-* in terms of namespace, the driver uses either qlge_, ql_ (used by
>>>-  other qlogic drivers, with clashes, ex: ql_sem_spinlock) or nothing (with
>>>-  clashes, ex: struct ob_mac_iocb_req). Rename everything to use the "qlge_"
>>>-  prefix.
>>You only renamed ql -> qlge. The prefix needs to be added where there is
>>currently none like the second example of that text.
>Thank you for reminding me of the second example!
>>Besides, the next patch reintroduces the name struct ql_adapter.
>Oh, there is still a left-over ql_adapter in qlge.h (I renamed ql->qlge
>after initializing the devlink framework earlier but did a git rebase
>to make the order of the changes more reasonable). Thank you for the

Btw, is there a way to configure kernel building to let the compiler
discover this kind of issue automatically?

>Best regards,

Best regards,

Powered by blists - more mailing lists