lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 19 Oct 2020 21:21:26 -0600
From:   David Ahern <>
To:     Jakub Kicinski <>,
        "Keller, Jacob E" <>
Cc:     "" <>,
        Jiri Pirko <>,
        Shannon Nelson <>
Subject: Re: [iproute2-next v3] devlink: display elapsed time during flash

On 10/19/20 1:20 PM, Jakub Kicinski wrote:
> On Mon, 19 Oct 2020 19:05:34 +0000 Keller, Jacob E wrote:
>>> The DEVLINK attributes are ridiculously long --
>>> DEVLINK_ATTR_FLASH_UPDATE_STATUS_TIMEOUT is 40 characters -- which
>>> forces really long code lines or oddly wrapped lines. Going forward
>>> please consider abbreviations on name components to reduce their lengths.  
>> This is probably a larger discussion, since basically every devlink attribute name is long.
>> Jiri, Jakub, any thoughts on this? I'd like to see whatever abbreviation scheme we use be consistent.
> As David said - let's keep an eye on this going forward. We already 
> pushed back with Moshe's live reload work.
> If you really want to make things better for this particular name
> you could probably drop the word _STATUS from it.

and typical strategies - like dropping vowels.

DEVLINK_ATTR_ is the established prefix so every attribute starts at 13
characters. In this case dropping STATUS and shortening TIMEOUT so it
becomes DEVLINK_ATTR_FLASH_UPDATE_TMOUT does not overly harm the
readability yet drops the char count to 31. Still long but is an example
of what can be done.

Powered by blists - more mailing lists